Hello Guest it is March 06, 2021, 12:23:31 AM

Author Topic: Help with Mack3 and Bobcad V23  (Read 3072 times)

0 Members and 1 Guest are viewing this topic.

Help with Mack3 and Bobcad V23
« on: January 11, 2010, 06:51:54 PM »
Hi, a newbie to Mack3 and Bobcad V23, Just completed building by CNC machine and calibrated the x, y, and z axis to a repeatability of */- 0.0005 when a x, y or z value is entered in Mach3 MDI ALT2 input field. I then tested MACH3 using the roadrunner example provided with MACH3 and that worked fine. I’m now trying to interface Bobcad V23 with Mach3. As a test I’m using the Mill 2 axis engraving function to engrave CNC-TEST. I was able to create the gcode for MACH3-MILL-NoATC.MILLPst and was able to load it into Mach3 and ran the gcode using the simulator on a machine running vista and code operated as expected. Next I load the gcode on the machine that’s being used to control stepper motors that running XP and the simulator run and it worked as expected. When the gcode is run with the stepper powered up it sends the X and Y axis uncontrollable from one end of axis to the other and does not cut the letters. I’m not sure why this happens does any one have any ideals? 

Offline Fastest1

*
  •  920 920
  • Houston, TX
    • View Profile
Re: Help with Mack3 and Bobcad V23
« Reply #1 on: January 12, 2010, 07:24:54 PM »
Have you asked Sorin? He teaches the BC classes, he might know why. Here is his forum http://www.cadcamtrainer.com/forums/index.php.
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)

Offline Mc2

*
  •  31 31
    • View Profile
Re: Help with Mack3 and Bobcad V23
« Reply #2 on: January 14, 2010, 06:56:09 PM »
That post for bobcad is intended for someone using work offsets and home switches. Try stripping the G54 commands out of your program or when you set your zero postions make sure that your work offsets are cleared out. I got tired of doing this so I removed the G54 from the post that Bobcad uses.


Let me know if this helps.
Jim.
Re: Help with Mack3 and Bobcad V23
« Reply #3 on: January 16, 2010, 08:25:53 PM »
Thanks for the respones Fastest1 and Mc2 I found the problem. The units for the motor setup had defaulted back to MM instead of IN. This caused the large movements.