Hello Guest it is October 16, 2019, 09:15:55 PM

Author Topic: Converting Sherline Linux/EMC to Windows/Mach3  (Read 3878 times)

0 Members and 1 Guest are viewing this topic.

Converting Sherline Linux/EMC to Windows/Mach3
« on: December 22, 2009, 06:32:45 PM »
I bought Sherline's complete package, including the PC pre-loaded with Linux and EMC. It was a start; I didn't like it. Besides, we'll be picking up a Tormach and it uses Mach3, so the idea was to make both the same (in contect.)

Conversion went OK; installed a new HD with WIndows XP and then installed the Sherline version of Mach3 that I installed from a 3rd party site. Got the thing up and going, but there were two odd quirks; one was a quick fix and the other remains an issue. First: I'd installed the XYZ cables as labled on the Sherline box (which were correct under Linux) but found that I had to swap the X and Y cables to get them to control the right motors. Odd, but not a big deal. Second: Still an issue; I was just giving it some G codes under MDI to check things out, and there is one quirk. X and Z are fine, but Y seems to have this doubling thing going on: I'll give it say Y1 and the table moves 2" in the Y direction. X and Z don't do this. I'm guessing there's a tweak to make under some screen? Anyone else had this problem?

Thanks!
Dave in MT
Re: Converting Sherline Linux/EMC to Windows/Mach3
« Reply #1 on: December 22, 2009, 06:46:42 PM »
Dave,

Have a look at the Mach3 manual under the configuration settings.

Basically, you can set which parallel port pins are used to drive which axes. You could change the configuration of these pins so that you don't have to swap the cables around.

Also you need to set up the step/inch for each axis. It sounds like it is wrong for the Y-Axis.

The sherline controller is a 1/2 step controller from memory. So, with a 200 steps/rev motor and a 1/2 step controller, and a 20 turns/inch leadscrew, you should have the steps/inch set to;

200 x 2 x 20 = 8000 step/inch


Cheers,


Peter.
----------------------------------------------------
Homann Designs
http://www.homanndesigns.com
email: peter at homanndesigns.com
Re: Converting Sherline Linux/EMC to Windows/Mach3
« Reply #2 on: December 23, 2009, 05:17:12 PM »
I know a fellow who will convert shortly to mach 3. Can i get a copy of the pin setup that you are using after you get your x/y swapped? Might save some time figgerin it out.
Re: Converting Sherline Linux/EMC to Windows/Mach3
« Reply #3 on: December 24, 2009, 12:36:40 AM »
I'll be glad to post when I've got it figured out. I've paused to download and read all the docs. I had a crash course in Mach3 when I took a CNC class at Tormach, but everything was all set up for their machine. Need to back up and nail down these details.
--Dave in MT
Re: Converting Sherline Linux/EMC to Windows/Mach3
« Reply #4 on: January 21, 2010, 02:50:44 PM »
The saga continues. The "backwards" X and Y connections turned out to be my teenage son who thought switching a couple of plugs was funny. Ha ha. Switched those back, and I can say definitely that the labels on the Sherline box (formerly Linux, now Windows and Mach3) match up just fine under Mach 3. Problem solved.

After playing with the system, I've discovered another hurdle that has to be jumped every time you cold boot the system. The system needs a kick in the head to get going. For example, I'll go into MDI and try giving it an X or Y command. Nothing. I then use the arrow keys to jog the system, click back in the MDI box, and voila, it responds. I'm guessing, but even though you see the long string of system settings at the top right of the screen, I'm not convinced everything takes at startup. I wrote a little program called "wakey wakey" to set things, cancel offsets, etc. and then just jog the steppers a bit to get their blood flowing.

One fairly big mystery remains: (Noticed most in MDI by the way.) I'll give it an x.1 just to give it a nudge for testing, and it'll go a full inch. I'll then go x0.1, even though it's not supposed to need the leading zero, and I might get .1 inch or I might get another inch. In fact, often times if I type in the exact same command, I get no response at all. (Yep, I'm trying to stay aware of o versus 0, etc.) However, if I change the value to say x0.2, off it goes. Always works if I change the value, but most often does not work if I repeat a command. I have the same issues with Y; for some strange reason it will ignore the decimal point for a while. However, after dinking around for a while, things seem to settle down and things react as I ask them to, although still not 100%. I am totally baffled by this. Again, all this is in MDI. Running a program seems more reliable, but even here I get some oddball stuff. For example, a program I ran last night had an x.3, which it did fine, but a couple steps later I'll give it an x-.3 and it shoots farther back than the x.3 starting position.

So, something, somewhere, is doing some random scaling or something...I just can't figure it out. Help?

Re: Converting Sherline Linux/EMC to Windows/Mach3
« Reply #5 on: September 22, 2010, 01:46:09 PM »
Hi Sherlline 2000 Mill
Iv also been running EMC2 Successfully but would like to run Mach3...
Where are the ports and pin settings for a Sherline 2010 Mill standard setup?  Iv emailed Sherline.
There seems to be little on the net.  I wonder what iv missed.....not that Sherline tick box though on Mach3 screen I got that. 

I use the printer cable but that is not a prob.  I'm using a separate computer for xp/Mach3 and have ubuntu Linux for emc2 which works...

Just aside note..
There are no limit switches on the Sherline Mill as its construction and small size allows survival with out them.   I know ... iv survived.
Soft limits sound a good idea..

HELP  a list of ports and pins or screen shots would be great..