Hello Guest it is August 12, 2020, 08:42:17 PM

Author Topic: Limit - Homing Problem  (Read 2642 times)

0 Members and 1 Guest are viewing this topic.

Limit - Homing Problem
« on: December 03, 2009, 08:33:48 PM »
I watched the video and read a bunch of posts but it seems my answer wasn't there...
I have a couple problems

1. When I start the machine and reference all the axes the Machine coordinates go to 0.500 just like they should, because I have it set to move 0.50 off the limit switch. The problem is that I am nowhere near the limit switch and the machine thinks its home...I'm sure there is some setting that is off ?t I don't recall changing anything and it was working ok.

2. I currently have the y axis set to Home Negative because it won't home to +Y. Any Ideas - are these two problems related?
I'm pretty new to all this and thought maybe the problem is caused by soft limits - I extended the soft limits to beyond the travel the table id capable of and no real change..unless I didn't push the magic butoon or something...

I'm going out to have another go at it because it seems that after I write about a problem it goes away...8-)


Bill

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Limit - Homing Problem
« Reply #1 on: December 04, 2009, 03:03:26 AM »
First thing to say is that your machine will not move off by 0.500 but rather when the switch closes again it will set the Machine Coordinates to 0.500 but not move to that position away from the switch.

I think your problem sounds like you have noise on your home switch wiring and what is happening is Mach starts homing, the noise makes it look to Mach as if the switch has been hit. Mach then reverses and sees the switch close again (due to noise) and sets that as the home position.
 Softlimits will have no affect on the homing move other than throw up an error if you have the soft limits set wrong, this error will only happen after the homing is done.
 Try setting the debounce interval to 2000 in General Configs and see if that helps your homing issues, if it does then you have confirmed you have noise issues and it is best to try and sort these out by making sure the wiring to the switches is shielded and properly grounded.

Hood
Re: Limit - Homing Problem
« Reply #2 on: September 25, 2012, 11:45:16 AM »
Had the same problem and this solution worked 100% for me.

X axis worked fine, y axis was the problem. The Y axis home switch wiring runs alongside the stepper motor wires along the gantry (Plasma Machine).
Classic recipe for induced noise.

Sorted... Thanks

Art