Hello Guest it is August 20, 2019, 10:38:44 AM

Author Topic: Can't jog or MDI??  (Read 3609 times)

0 Members and 1 Guest are viewing this topic.

Can't jog or MDI??
« on: November 25, 2009, 11:02:49 PM »
OK, I must be the worlds biggest idiot ??? I thought this was gonna be easy.
I'm putting together a computer for a couple future machines. It's only a 600MHz PIII but its something I already had layin around. Also what I had was Windows 2000. Did a fresh install and did all the updates to 2K. Then installed the latest Mach3 to get a feel for it (yes, I did the vital reboot before running). Initial drivertest result was OK but had some large spikes in the graphic window, and the colorbar turned yellow once in a while. I disabled the wireless network and that cleared up to system excellent or at least system stable the whole time.
OK, so I fire up Mach and start going thru the simple stuff. Hit the reset button and it's OK. type in a feedrate (50) and its OK. go to MDI screen and type in G00 X1.1 Y2.2 expecting to see the DRO's change, but nothing. Open the MPG and try to jog, but nothing there either.
I'm pretty embarrassed here, and must be missing something pretty basic, but just going thru the manual in order and cant get it to do like it says.
I have nothing connected to the paraport, and the drivers installed with no errors or problems. What am I missing? Do I have to do a configuration before this will work?

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
Re: Can't jog or MDI??
« Reply #1 on: November 25, 2009, 11:31:05 PM »
You would have to tune the motors for mach to know how far it went theoretically. So some steps per unit will have to have been entered. So yes on the configuration.
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
Re: Can't jog or MDI??
« Reply #2 on: November 25, 2009, 11:34:01 PM »
Have you done any of the configuration of the native units, steps per unit, accel and velocity tunings etc? Even if you dont have it hooked to a machine it has to think it is going a specific distance.
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Can't jog or MDI??
« Reply #3 on: November 26, 2009, 02:28:57 AM »
Can you attach your xml please.
Hood
Re: Can't jog or MDI??
« Reply #4 on: November 26, 2009, 10:45:09 AM »
Thanx guys...figured out what I was missing. I assumed that the ports and pins config was for the physical output only. Once I enabled x, y, and Z there, it's OK. The motor tuning had default settings in it. Like I said, I was just stepping thru the manual in order, and assumed (yeah I know!!) it had a basic default setup already done. I guess I can see that being even more dangerous though. Maybe I should just read the whole thing first.
Thanx again, but I'm sure it aint the last question.

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
Re: Can't jog or MDI??
« Reply #5 on: November 26, 2009, 11:56:53 PM »
You can read it all and though it will help, there will still be times when it doesnt make any sense at all. Enjoy
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)
Re: Can't jog or MDI??
« Reply #6 on: November 03, 2010, 07:48:37 AM »
You can read it all and though it will help, there will still be times when it doesnt make any sense at all. Enjoy
too true... but whats sense anyway?

answers my prob.... surprisingly hard topic to find on search...