Hello Guest it is January 20, 2020, 12:11:44 PM

Author Topic: SmoothStepper (Soigeneris) up and running!!!!  (Read 8776 times)

0 Members and 1 Guest are viewing this topic.

SmoothStepper (Soigeneris) up and running!!!!
« on: November 22, 2009, 05:05:20 PM »
First of all, kudos to Jeff for a KILLER product!  The STDR-4C driver kicks butt! I had an issue iwth SmoothStepper's config not saving my values but reloaded the drivers, profile and XML and we're cooking with gas.  Two issues I don't know how to solve - 1) How do I get the Mach3 Jog Speed functionality back?  I really liked the "half speed - full speed" feature that I had with Mach 3 using the parallel port.  Now, the jog speed is "tied" to the motor max velocity and I cna't figure out how to get half spped with just the jog key and full speed with "Shift/jog key." And now my Auto Tool Zero is DEAD! It worked like a champ using this VB script:
CurrentFeed = GetOemDRO(818)
PlateThickness =2.040
ProbeFeed = 5

Code "G90 F" &ProbeFeed

If GetOemLed(825)=0 Then
Code "G4 P3"
Code "G31Z-5 F" &ProbeFeed
Code "G4 P0.25"
While IsMoving()
Sleep(100)
Wend
ZProbePos = GetVar(2002)
Code "G0 Z" &ZProbePos
While IsMoving()
Sleep(100)
Wend
Call SetDro (2,PlateThickness)
Sleep(100)
Code "G4 P0.5"
Code "G0 Z2.290"
Code "(Z axis is now zeroed)"
Code "F" &CurrentFeed
Else
Code "(Z-plate is already activated)"
Exit Sub
End If 
 - but now it just initiates a short dwell then nothing. Anyone have a "new" Auto Tool Zero script that works with version .032 and SmoothStepper???

Offline Jeff_Birt

*
  •  1,107 1,107
    • View Profile
    • Soigeneris
Re: SmoothStepper (Soigeneris) up and running!!!!
« Reply #1 on: November 22, 2009, 06:10:56 PM »
Glad to hear you have it up and running.

How are you mapping the probe input to the LED register you are reading? Creating an onscreen LED mapped to the same value will give you a visual indication that yo are seeing the input.
Happy machining , Jeff Birt
 
Re: SmoothStepper (Soigeneris) up and running!!!!
« Reply #2 on: November 22, 2009, 07:15:04 PM »
I am "cheating" for now.  I'm using input #4 as the probe input.  I see the "Digitize" LED react to the probe on the Diagnostics screen(dark with the probe unactivated, lit with it activated).  Electrically, the probe is working fine but the Auto Tool Zero doesn't run the VB script at all.  The script I posted is the same I was using with ver .032 and the Hobby CNC parallel port set-up and it worked perfectly.  Now all I get is a Dwell indication for about 2 seconds then nothing at all.  No Z movement, no status change, nothing.

Offline Jeff_Birt

*
  •  1,107 1,107
    • View Profile
    • Soigeneris
Re: SmoothStepper (Soigeneris) up and running!!!!
« Reply #3 on: November 23, 2009, 11:51:04 AM »
Oh, on the jog speed: did you set the 'Slow Jog Rate' % in the jog control fly out? Works for me here...

I don't use a touch probe myself so I'll have to do some experimentation on that one. I do have other customers that use it so I know it works with the G540/SS combo.
Happy machining , Jeff Birt
 
All issues resolved!
« Reply #4 on: November 23, 2009, 04:11:35 PM »
Jeff, thanks for the quick responses.  I figured out all the issues.  I found a script that makes Auto Tool Zero work perfectly with Ver .032, SmoothStepper and the G540.  I also remembered where the jog speed settings were "hiding" early this morning.  Thanks again for the great driver! And the external spindle relay.  Your products are FIRST RATE!  Here is the VB script for a good, reliable Auto Tool Zero, but with three notes: 1) Add your Z plate/probe height to the distance you want to retract and enter that value in the "change the Z retract height" line 2) This works for the standard Mach screen, I don't know if it will work with any others 3) Input High or Low muxt be correct for the style of plate/probe being used - if not correct, you won't get past the "Z plate is already grounded" error message
CurrentFeed = GetOemDRO(818) 'Get the current feedrate.
PlateThickness =2.040

If GetOemLed (825)=0 Then
DoOEMButton (1010)
Code "G4 P3" 'Time to get to the z-plate, 3 seconds
Code "G90 G31 Z-2 F4" ' probing move, can set the feed rate here as well as how far to move
While IsMoving()
Wend
ZProbePos = GetVar(2002)
Code "G1 Z" &ZProbePos
While IsMoving ()
Wend
Call SetDro (2, PlateThickness)
Sleep(120)
Code "G0 Z2.785" 'Change the Z retract height here to what you want, must be higher than touch plate
Code "(Z axis is now zeroed)"
Code "F" &CurrentFeed 'returns to prior feedrate
Else
Code "(Z-Plate is grounded, check connection and try again)"
End If
Exit Sub   
Re: SmoothStepper (Soigeneris) up and running!!!!
« Reply #5 on: November 25, 2009, 06:12:54 PM »
Where can I find more info on teh Smoothstepper? Does this essentially function as a USB-to-Parallel converter?

Offline Jeff_Birt

*
  •  1,107 1,107
    • View Profile
    • Soigeneris
Re: SmoothStepper (Soigeneris) up and running!!!!
« Reply #6 on: November 25, 2009, 07:30:30 PM »
The SmoothStepper is an external motion control board that communicates with Mach3 through a USB port. It has two I/O ports that are mapped like a parallel port as well as a 3rd port designed to be easy to interface for encoders of various sorts. The manufacturers website is warp9td.com, and you can also find for sale at various dealers like my shop soigeneris.com.
Happy machining , Jeff Birt
 
Re: SmoothStepper (Soigeneris) up and running!!!!
« Reply #7 on: November 25, 2009, 08:25:35 PM »
So I can't just plug a Camtronics controller into a parallel port on teh back of this and have smoother stepping?

Offline Jeff_Birt

*
  •  1,107 1,107
    • View Profile
    • Soigeneris
Re: SmoothStepper (Soigeneris) up and running!!!!
« Reply #8 on: November 25, 2009, 09:27:04 PM »
Well, I do not have nearly enough information to even hazard to guess. please explain your situation a bit more.
Happy machining , Jeff Birt
 
Re: SmoothStepper (Soigeneris) up and running!!!!
« Reply #9 on: November 25, 2009, 09:35:28 PM »
I have a Camtronics controller plugged into a parallel port on an XP-running machine that works fine. If I wanted to upgrade to a laptop without a Parallel port running Win7, would this be the thing I plug intop the USB on the pc, and then plug the camtronics controller into that, or would I have to modify the controller?