Hello Guest it is August 17, 2019, 05:32:45 PM

Author Topic: Z late getting to final depth  (Read 3153 times)

0 Members and 1 Guest are viewing this topic.

Z late getting to final depth
« on: November 20, 2009, 12:01:12 PM »
Hi, Let me start out saying I'm new to Mach. I have just finished building my table and have a problem. Whenever I start to make a cut my Z axis doesn't get to it's final depth before x and y start to move. It will get there, but the first part of the cut is shallow.
Joe
Re: Z late getting to final depth
« Reply #1 on: November 20, 2009, 01:12:37 PM »
Pretty much has to be the way the g-code is written.

G1 X1 Y2 Z-0.5  - will move all three axes at once, so the tool ends up at X1, Y2, Z0.5 at the end of the move

G1 Z-0.5
G1 X1 Y2  - will move Z to -0.5, *then* move X/Y

Regards,
Ray L.
Regards,
Ray L.

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Z late getting to final depth
« Reply #2 on: November 20, 2009, 01:41:07 PM »
I think it could also be CV mode. I saw this over the weekend when cutting some parts. With CV mode, the X and Y start moving before the Z stops.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Z late getting to final depth
« Reply #3 on: November 20, 2009, 11:05:56 PM »
I did change it from CV mode but cut was real jerky. I've been getting the G codes via Lazycam. Could it be a setting in LC?
Joe
« Last Edit: November 20, 2009, 11:07:43 PM by jbjackson »

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: Z late getting to final depth
« Reply #4 on: November 21, 2009, 12:30:10 AM »
Hi, Joe

Post your problem G-code and DXF files your having issues with, Use the REPLY button and Attach option, Welcome aboard.

Chip

Offline Tweakie.CNC

*
  • *
  •  7,882 7,882
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Z late getting to final depth
« Reply #5 on: November 21, 2009, 03:29:34 AM »
If you are using LazyCam then it will create the Z axis leadIn's unless you set the 'LeadIn size' to zero or uncheck the 'LeadIn on' box. (under the 'layers' tab click 'layer leadin settings').

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.