Hello Guest it is July 21, 2019, 05:38:59 AM

Author Topic: My Lathe has gone crazy, not on toolpath, Thread Cutting Issue  (Read 4118 times)

0 Members and 1 Guest are viewing this topic.

Offline tjhj

*
  •  26 26
    • View Profile
My Lathe has gone crazy, not on toolpath, Thread Cutting Issue
« on: November 19, 2009, 11:31:49 PM »
Hello,
I have a MicroMark 7x14, retrofitted to CNC. I finally got around to getting an index pulse so I now have spindle speed to do threading. I am using an opto interrupter, with a disc cut about 45deg to create the pulse.

I have been using both the simple and complex threading wizard, but it goes diagonally starting at the correct depth then moving away.
It appears to be making the correct step in each time, but then makes the triangle away from the piece in stead of making a thread.

I took a video of the screen to show what it is doing. And the machine path matches the new white line it is drawing in the video.
http://www.youtube.com/watch?v=etNtx_wk9D0
I have the taper set to 0 deg, and in feed is at 29.5 degrees.
I have tried it in both radius and diameter mode same results.
Why is it doing this?

It also doesn't appear to be starting at the same part of the thread, like using a thread dial gauge and starting on a different number every time. Any Ideas?

Also I don't have the spindle control done yet. So why doesn't it change the feed in proportion to the spindle speed? If I speed it up or slow it down, the feed remains constant. I am assuming that I have something set wrong, any ideas?

Any ideas or suggestions are greatly appreciated.
Thank you for your time,

TJ
« Last Edit: November 19, 2009, 11:34:25 PM by tjhj »

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
Re: My Lathe has gone crazy, not on toolpath, Thread Cutting Issue
« Reply #1 on: November 20, 2009, 12:27:48 AM »
I am about to install a Homann designs speed control along with an encoder, so I will be watching this thread. I have never threaded via cnc and it loooks great. Judging from your post since the speed control isnt finished how would it compensate? With just the feed? I would think timing of both is the way it needs to be. I am sure you will see me posting similar questions soon.
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)

Offline Dan13

*
  •  1,244 1,244
    • View Profile
    • DY Engineering
Re: My Lathe has gone crazy, not on toolpath, Thread Cutting Issue
« Reply #2 on: November 20, 2009, 02:19:32 AM »
Which version of Mach are you using. Older Mach versions used to have various strange issues like the one you're seeing. The latest Mach version is supposed to have threading fixed for good.

Daniel

Offline RICH

*
  • *
  •  7,342 7,342
    • View Profile
Re: My Lathe has gone crazy, not on toolpath, Thread Cutting Issue
« Reply #3 on: November 20, 2009, 08:55:11 AM »
tjhj,
A few questions first.
1. What version of Mach are you using?
    (You should be using 3.042.032.)
2. Can you post the file you are using?
3. Did you take a look at the Threading on the Lathe writeup in Members Docs?
4. Can you post your XML?
5. Post a screen shot of both input screens of the Simple Threading Wizard you are using after you have input
    the values.
RICH
   

Offline tjhj

*
  •  26 26
    • View Profile
Re: My Lathe has gone crazy, not on toolpath, Thread Cutting Issue
« Reply #4 on: November 20, 2009, 01:12:34 PM »
Ok.
Thanks for the help so far.

I was using 42.020...
And I just upgraded to 42.032, but now I have lost my spindle speed. I checked ports, pins, de bounce, and that it is working correctly.
I am using my second parallel port, Index input, pin 15.
Prior to upgrading I copied the old mach folder, if I run the old version 020 again I have my spindle speed just fine.

Any Ideas?

TJ
« Last Edit: November 20, 2009, 04:15:26 PM by tjhj »

Offline tjhj

*
  •  26 26
    • View Profile
Re: My Lathe has gone crazy, not on toolpath, Thread Cutting Issue
« Reply #5 on: November 20, 2009, 04:25:29 PM »
Ok thank you all for the help,
Here is everything you have asked for. (I think)
Btw its going to take me some time to work through the lathe threading doc.
So for spindle speed,
Under the diagnostics screen, it shows the pulse correctly with the light lighting up.

I have tried the following
Switching the port numbers, so #1, is now #2 ect.
Turning on Just the timing input, or index, both active high and low, on both ports. Nothing.
If I run my backup copy of 42.020 turn, I do not have the timing input enabled, just index, and I get a spindle speed output just fine.
I have checked all the settings I can think of and I can not find any thing different from the settings in .020 and .032 versions.
The attached xml file, is from after the update to version 42.032.
« Last Edit: November 20, 2009, 04:32:45 PM by tjhj »

Offline RICH

*
  • *
  •  7,342 7,342
    • View Profile
Re: My Lathe has gone crazy, not on toolpath, Thread Cutting Issue
« Reply #6 on: November 20, 2009, 04:35:02 PM »
TJ,
Did you take a look at the Threading on the Lathe write up?
See Section 7, in particular 7.1.2 and the associated comment as you need to uncheck Relay Control and additionly you have to turn the spindle on.
RICH
Re: My Lathe has gone crazy, not on toolpath, Thread Cutting Issue
« Reply #7 on: November 20, 2009, 04:37:05 PM »
In version .032 spindle must be on before you will get a speed indication. Either click on the spindle button on your screen, or run an M3 command from either the MDI input or from a G code program.

Peter

Offline tjhj

*
  •  26 26
    • View Profile
Re: My Lathe has gone crazy, not on toolpath, Thread Cutting Issue
« Reply #8 on: November 20, 2009, 04:42:39 PM »
Ok I will try that as soon as I am home,
Im reading... Thank you for the doc.
TJ

Offline RICH

*
  • *
  •  7,342 7,342
    • View Profile
Re: My Lathe has gone crazy, not on toolpath, Thread Cutting Issue
« Reply #9 on: November 20, 2009, 05:09:24 PM »
 TJ,
1. in config>ports &pins>spindle setup.....check Use spindle feedback in synch mode and also uncheck disable spindle relays
2. in general config check / use exact stop and not constant velocity mode
3.in config>plugins you may want to enable Trun Diagnostics -1.00.1

The thread code you posted works just fine here ( i did change the rpm here for my try of it ).

Now before you go doing any actual threading, read the write up and consider doing the axis tests.
RICH