Hello Guest it is August 18, 2019, 02:06:12 PM

Author Topic: Trouble with second printer port  (Read 2419 times)

0 Members and 1 Guest are viewing this topic.

Offline Pich

*
  •  11 11
    • View Profile
Trouble with second printer port
« on: November 19, 2009, 05:22:04 PM »
I have installed a second PCI printer port on the mother board and did a printer test and works good.  My problem is that Mach3 will not respond to any control from that port.  In control panel the driver has a starting address of E010 I entered it in the Mach setup screen. checked port #2 enabled and checked use 2 -9 as inputs.  Could it be the address is wrong? I thought printer port 2 address is 278.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Trouble with second printer port
« Reply #1 on: November 19, 2009, 05:40:24 PM »
It could be that the port is not a real port but just emulating a port, another possibilty is that it is not capable of being set for inputs on 2-9. Check by setting an input in ports and pins to port 2 pin 10 and then watch the LED for that input on the diagnostics page and see if it reacts when you short pin 10 to a gnd pin.
Hood

Offline Tweakie.CNC

*
  • *
  •  7,882 7,882
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Trouble with second printer port
« Reply #2 on: November 20, 2009, 02:49:28 AM »
You can confirm the address of your second printer port from:- control panel/hardware/device manager/ports/properties/resources.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.