Hello Guest it is September 21, 2019, 10:53:22 PM

Author Topic: z-axis plunging  (Read 5541 times)

0 Members and 1 Guest are viewing this topic.

Offline bjcnc

*
  •  10 10
    • View Profile
z-axis plunging
« on: November 19, 2009, 02:34:32 PM »
when my z axis is plunging into the matterial it goes to the max z depth for the entire piece and either locks up the whole machine or drags my piece of wood with it  does anyone have any ideas as to what it could be

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: z-axis plunging
« Reply #1 on: November 19, 2009, 02:37:37 PM »
Your code?
Hood

Offline bjcnc

*
  •  10 10
    • View Profile
Re: z-axis plunging
« Reply #2 on: November 19, 2009, 03:30:00 PM »
here is the begining dunno how to send it all because it is too many "words"
O0001(AEMBOS1A.NC)
N1 G00 G17 G20 G40 G49 G80 G90
N2 T1 M6 (CONIC-R  1/8 - DEG 15 - R 0.025 )
N3 G00  X0.  Y0. M03
N4 G43H1  Z0.1 M8
N5 G01 Z-0.2 F40
N6 X0.7677
N7 X0.7879 Z-0.1661
N8 X0.798 Z-0.1536
N9 X0.8081 Z-0.152
N10 X0.8182 Z-0.1536
N11 X0.8283 Z-0.152
N12 X0.8384 Z-0.1598
N13 X0.8586 Z-0.1975
N14 X0.8687 Z-0.2
N15 X1.3737
N16 X1.3838 Z-0.199
N17 X1.3939 Z-0.1873
N18 X1.404 Z-0.1818
N19 X1.4141 Z-0.1873
N20 X1.4242 Z-0.1818
N21 X1.4343 Z-0.1943
N22 X1.4444 Z-0.2
N23 X2.

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: z-axis plunging
« Reply #3 on: November 19, 2009, 03:46:47 PM »
Seems to be fine here, what do you have for offsets in the tooltable for tool 1?
Hood

Offline bjcnc

*
  •  10 10
    • View Profile
Re: z-axis plunging
« Reply #4 on: November 19, 2009, 03:52:28 PM »
they are all empty and at 0... the machine has sat idle for over a year now and before it sat it was working great just all the sudden started doing this

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: z-axis plunging
« Reply #5 on: November 19, 2009, 03:55:37 PM »
so what depth is it going down to?
Also if you want to attach your code and xml I can have a look with your settings. To attach you use the additional options button on the reply page. You will likely have to copy and rename your xml for the forum to accept it.
Hood

Offline bjcnc

*
  •  10 10
    • View Profile
Re: z-axis plunging
« Reply #6 on: November 19, 2009, 04:04:16 PM »
here is the code atleast it should be let me try to find the xml

Offline bjcnc

*
  •  10 10
    • View Profile
Re: z-axis plunging
« Reply #7 on: November 19, 2009, 04:11:35 PM »
is this the xml you were asking for if not sry can you explain exactly what it is

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: z-axis plunging
« Reply #8 on: November 19, 2009, 04:49:27 PM »
Just tried with your xml and it seems fine, first move on Z is to 0.1 then it goes down to -0.2

What are you seeing for Z moves?
Hood

Offline bjcnc

*
  •  10 10
    • View Profile
Re: z-axis plunging
« Reply #9 on: November 19, 2009, 04:53:28 PM »
we place the z on the or right above the piece of wood and zeroing it. then when we start to run the gcode  it just dives right down to -0.2