Hello Guest it is July 08, 2020, 01:05:03 AM

Author Topic: Second parallel port for use with THC  (Read 2579 times)

0 Members and 1 Guest are viewing this topic.

Second parallel port for use with THC
« on: November 13, 2009, 10:08:40 AM »
Hi All..

I seem to be having an issue with the second parallel port.  It seems to install fine and device manager thinks it's working.  If I check IO addresses from a DOS command prompt using debug it looks like the second port is at 0x278 but when I look at its resources in device manager, there are two lines.  The first is 9000 - 9007 and the second is 9400 - 9407.  I've tried 278, 9000 and 9400 in Mach with no luck. I'm coming to the conclusion that the PP is no good and I've got another (better) one on the way.

In the mean time, is there a simple way to test the PP port in Mach by grounding certain pins?  If so, which pins and where would I look in Mach to see results?  Any other thoughts on the topic would be greatly appreciated.

Thanks very much....

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Second parallel port for use with THC
« Reply #1 on: November 13, 2009, 10:15:57 AM »
You can test in Mach by setting some of the Inputs in Mach to 2 and pin numbers to what you are using, then short these pins to grnd pins. 18 to 25 on a PP are Gnd pins. You can then look on the diagnostics page and see if the LED states change when you short the pins.

Some parallel ports can not be set up to have pins 2-9 set as inputs so best to check with pins 10,11,12,13 and 15 first.
Hood

Offline Tweakie.CNC

*
  • *
  •  8,350 8,350
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Second parallel port for use with THC
« Reply #2 on: November 13, 2009, 12:20:55 PM »
If it helps, I use two ports. The address in Mach Config for Port 1 is 0x378 and Port 2 is 0x278.

Tweakie.
KEEP SAFE !
Re: Second parallel port for use with THC
« Reply #3 on: November 13, 2009, 04:40:26 PM »
Thanks guys...I made a simple test rig with 5 buttons to ground 10, 11, 12, 13 and 15.  Turns out the PP was working fine.  I had a bad cable. 

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Second parallel port for use with THC
« Reply #4 on: November 13, 2009, 05:11:21 PM »
:)