Hello Guest it is October 22, 2019, 07:43:13 AM

Author Topic: Limit/Index Wiring  (Read 2948 times)

0 Members and 1 Guest are viewing this topic.

Limit/Index Wiring
« on: January 08, 2006, 07:24:29 AM »
I am attempting to wire up limit and spindle index sensors using some small honeywell opticals.  I have a 10K pull up in the circuit. My issue is that it does not seem that the circuit will draw the port pins low consistently.  It will draw the port down to ~1.4V when bread boarded and 1.8V when soldered to a piece of PCB.

When first connected it work fine, when I block the sensor, it drive the output high (~4.5v) when I unblock the sensor, the voltage does not go low enough to reset the LED on the Mach 3 Diagnostics screen.

Basic schematic

                            to LPT Pin
                                l
              10K             l               NPN
+5v-----^^^^^-------l------------\_/-------- Gnd



I have tried using larger pullups , up to 1M, it doesn't seem to make a significant difference.

Any thoughts?
Randy
Re: Limit/Index Wiring
« Reply #1 on: January 08, 2006, 07:49:35 AM »
Have you tested it by taking the pull up off? You are pulling the port down and what you are getting from the resistor. I don't know your sensor but it may only be able to sink a very small amount of current.

Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Limit/Index Wiring
« Reply #2 on: January 08, 2006, 08:04:10 PM »
Brian,

Thanks, that worked, the schematic now looks like this:

To LPT Pin
        l
        l               NPN
        l------------\_/----------Gnd

Am I correct in assuming that now the transistor is now simply sinking the current  from the port, whereas before it was trying to sink the port and the power coming through the resistor?

BTW here is the link to the sensor:  http://catalog.sensing.honeywell.com/datasheet.asp?FAM=infrared&PN=HOA1887%2D012

Thanks for your help

Randy