Hello Guest it is September 21, 2021, 04:30:52 PM

Author Topic: G0 Problem  (Read 2433 times)

0 Members and 1 Guest are viewing this topic.

G0 Problem
« on: October 20, 2009, 08:12:11 PM »
I have been having a problem with Mach3 for a while now that I can't figure out. About a year ago I changed from WinCNC to Mach3, changed my drives, etc., and for the most part everything works fine. The only problem I've had is, when I manually type in a 'G0 X## or Y##' command, just about every time (99%+) the axis will move anywhere from 2" to 24" (+/-) and both axis will lock up and the motors will 'scream' until I hit <ESC>. I can jog the machine in high speed with no problems, and it has only happened once or twice in a program (obviously with catastrophic results to the part), but it happens almost EVERY time I use a G0 manually. At that point I have to go back and re-home my axis to make sure the machine knows where it is.

I have experimented with the ramp speed, which is currently set to max time to full speed, and the top speed (currently set far slower than I was running in WinCNC), but nothing has helped to this point. I looked under the FAQs and didn't find anything addressing this. Does anyone have any idea what this problem may be.

I only changed the interface and software, the drivers and motors are the same ones I ran under WinCNC.
« Last Edit: October 20, 2009, 08:38:22 PM by kthomson »

Offline RICH

  • *
  •  7,419 7,419
    • View Profile
Re: G0 Problem
« Reply #1 on: October 21, 2009, 12:28:59 AM »
I suggest the following.
Whatever your max velocity is ( were the motors will start to skip ) set your velocity to 70% of that max setting.
Adjust the acceleration also. That should keep you from skipping steps.

Offline Hood

  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: G0 Problem
« Reply #2 on: October 21, 2009, 02:58:44 AM »
Your drives may require a wider pulse, try setting the pulse width and Dir prechange to 5 or even trying sherline mode.
Re: G0 Problem
« Reply #3 on: October 21, 2009, 02:29:11 PM »
Rich: I don't know what the max speed is, but I already have it set FAR below the max speed I was running in WinCNC, where I never had this problem. I have also already set the acceleration ramp to MAX (longest time from 0 to max speed) but it has not helped.

Hood: I'll give that a try this weekend. I won't be home again until Saturday, but this is something I have not tried.

Again, it only seems to be a problem when using the G0 command in manual mode, in a program it works fine, which is what I find confusing.