Hello Guest it is November 12, 2019, 05:26:41 AM

Author Topic: Paralell Port on PCI Card  (Read 2219 times)

0 Members and 1 Guest are viewing this topic.

Paralell Port on PCI Card
« on: October 19, 2009, 09:04:48 AM »
I have done a search but cannot find anything relevant to my problem.

I have bought a new PC to use solely for mach3 however I have bought one without a paralell port build onto the motherboard (I think these are becoming rare to find on new PC's). Therefore I have bought a PCI card with a paralell port on it and have installed and loaded the driver which all seems fine.

My problem is when trying to run my controller it does not seem to work. I have another PC with a built in paralell port which runs my controller with no issues. I am using the same setting for both PCs. Do I need to use different pin numbers on the machine with the PCI paralell port or is there something I need to do inside mach3 or in system\hardware on the PC to get the PCI paralell port working with mach3?

Many thanks for your time
James
Re: Paralell Port on PCI Card
« Reply #1 on: October 19, 2009, 09:21:11 AM »
OK I have fixed it myself so thought I would post for anyone for the future.

I had to go into Control panel > System > hardware > device manager

Open up the ports section then double click the PCI paralell port name. Go to the resources tab then note down the 'I/O Range'

I used these settings on the first page of the 'ports and pins' page in Mach3 instead of the default '0x378'

Pressed OK and everything came to life.

Thanks
James

Offline bowber

*
  •  216 216
  • Kirkby Stephen,Cumbria, UK
    • View Profile
Re: Paralell Port on PCI Card
« Reply #2 on: October 19, 2009, 12:47:49 PM »
What was the PCI card?
It's handy to know of one that's worked for someone.

Steve