Hello Guest it is May 20, 2019, 07:10:29 AM

Author Topic: how to disable the toolpath display  (Read 6375 times)

0 Members and 1 Guest are viewing this topic.

how to disable the toolpath display
« on: October 15, 2009, 03:32:31 PM »
this weekend i tried cutting a high res lithopane and after i generated the g-code the file was about 80mb and had roughly 3.3 million lines. i found the option on the settings screen to turn off the toolpath but this keeps getting reactivated everytime i start mach3 back up again. when trying to load this file it also takes about 5 min to load and if i don't have the toolpath disabled the cnc looses steps all over the place...

how can i disable this so it does not get activated everytime i start mach3 since i really don't use it anyway..

thanks
James

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: how to disable the toolpath display
« Reply #1 on: October 15, 2009, 03:48:30 PM »
Open notepad and put the following in it

If GetOemLED(27) Then
DoOemButton (132)
Else
End
End If

Name it m111.m1s or similar and save it in your profiles macro folder. Next put m111 in the initialisation line on the general config page.
Each time you start Mach the macro will look at the LED for the toolpath and if its on it will press the button to disable it, if its not on then it will do nothing. When you initially start Mach it will probably be on but as soon as you press Reset it should shut off.

Hood
Re: how to disable the toolpath display
« Reply #2 on: October 15, 2009, 04:18:10 PM »
Open notepad and put the following in it

If GetOemLED(27) Then
DoOemButton (132)
Else
End
End If

Name it m111.m1s or similar and save it in your profiles macro folder. Next put m111 in the initialisation line on the general config page.
Each time you start Mach the macro will look at the LED for the toolpath and if its on it will press the button to disable it, if its not on then it will do nothing. When you initially start Mach it will probably be on but as soon as you press Reset it should shut off.

Hood


great i will try this tonight when i get home, thanks.
Re: how to disable the toolpath display
« Reply #3 on: October 15, 2009, 05:24:49 PM »
Hood i just tried it and i see that the status called the initialization macro but nothing happens. if i look at the "toolpath on/off" button it is still on.

in my initialization string i have "G80 m111" in the general config screen. i tried just the m111 but that did not work.

thanks
James

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: how to disable the toolpath display
« Reply #4 on: October 15, 2009, 05:27:22 PM »
did you place the m111.m1s in the macro folder of the profile you are using?
MDI m111 and see if it works.
Hood
Re: how to disable the toolpath display
« Reply #5 on: October 15, 2009, 05:55:55 PM »
Hood sorry i did not put the file in the actual macro/profile folder i just put it in the root of the mach3 folder where i was running the xml from. it worked great thanks for your help...

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: how to disable the toolpath display
« Reply #6 on: October 15, 2009, 06:08:49 PM »
:) no problem.

Hood