Hello Guest it is October 17, 2019, 02:12:49 AM

Author Topic: Run away jogging  (Read 3053 times)

0 Members and 1 Guest are viewing this topic.

Run away jogging
« on: September 08, 2009, 10:43:45 PM »
Was using the arrow keys to jog my mill last night when it took off wildly.  I had punched the key several times in succession  as I often do when trying to nudge the table one way or the other.  Suddenly the Y axis stepper continued to move after I had stopped pressing the key.  Although this has happened before, I don't know if pushing the direction key quickly in succession is the problem or if holding the key down caused the axis to run away.  I had released the key and the table continued to move.

Seems I have read of others experiencing this before but I could locate a thread regarding the problem (maybe it is a benefit   ;) ).  I cannot remember if the problem was a mach setting or if it is a microsoft keyboard setting.  I am running Windows XP 7.



Any assistance or answers appreciated.

Thanks

Bob@BobsShop
« Last Edit: September 08, 2009, 10:46:06 PM by BobsShop »

Online Tweakie.CNC

*
  • *
  •  7,949 7,949
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Run away jogging
« Reply #1 on: September 09, 2009, 09:56:14 AM »
Hi Bob,
Don't know if this is any help but I recently had a PC failure and had to use another PC which had Win XP SP2 installed and I experienced exactly the same problem as you have described. After much time wasted trying to resolve the problem I installed Win XP SP1 over the top of the existing installation and thereafter no problems at all.
It has to be something to do with the way the PC handles its polling routines and the way this is interpreted by XP SP2.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Run away jogging
« Reply #2 on: September 14, 2009, 06:10:36 PM »
Found a fix for this problem.  Following is from the MicroSoft website:

In detail, open the Control Panel,
if you're using Windows XP, double click the 'Accessibility Options' item.
In the Accessibility Options window, switch to the 'Keyboard' tab and
select the checkbox before the 'Use FilterKeys' option;

if you're using Windows Vista, double click the 'Ease of Access Center'
item and then click the 'Make the keyboard easier to use' link. In the
window opened, select the checkbox before the 'Turn on Filter Keys' option.

You will also need to select Filter options, click on settings, and select No Keyboard Repeat.

Bob@BobsShop
 

Online Tweakie.CNC

*
  • *
  •  7,949 7,949
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Run away jogging
« Reply #3 on: September 15, 2009, 02:33:08 AM »
Glad you found the answer Bob and thanks for posting the solution.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Run away jogging
« Reply #4 on: September 15, 2009, 08:24:40 AM »
Forgot to mention that this "fix," will really make typing in other programs a real pain.  My solution is to have the shop computer set  up for only Mach 3 use.  All programming, word processing, spread sheets, etc. is handled by the office computer. 

Bob@BobsShop

Offline mr.c

*
  •  40 40
    • View Profile
Re: Run away jogging
« Reply #5 on: September 16, 2009, 02:36:19 PM »
I went in and did this and basically lost control of my keyboard. I clicked the tab key to bring up the jog screen and nothing. So I had to go back and turn that back off.