Hello Guest it is May 14, 2021, 05:47:44 AM

Author Topic: Smooth Stepper Times Out.  (Read 3764 times)

0 Members and 1 Guest are viewing this topic.

Smooth Stepper Times Out.
« on: August 17, 2009, 03:33:53 PM »
I have a smooth stepper and if I am moving to a position and in mach, and at the same time click on say the homing/limits(tool table but can be any menu item) the Smooth stepper loses communications.
could this be the PC too slow?
celeron 2.4 gig
2 gig RAM
gforce mx video card
usb1.1

dose it matter if its usb 2.0 or 1.1?

Also when I get timeout error and rest wont clear it and have to restart mach.

any help will be apreciated.

« Last Edit: August 17, 2009, 06:45:26 PM by brianpretty »

Offline RICH

*
  • *
  •  7,419 7,419
    • View Profile
Re: Smooth Stepper Times Out.
« Reply #1 on: August 17, 2009, 10:46:28 PM »
Hmm....
You shouldn't be fooling around while your running your code. If you interupt the moves long enough,
then the SS buffer runs out.

I don't think it's the PC.  ?
RICH

Offline Jeff_Birt

*
  •  1,107 1,107
    • View Profile
    • Soigeneris
Re: Smooth Stepper Times Out.
« Reply #2 on: August 17, 2009, 11:14:39 PM »
How do you have the SmoothStepper configured? What are the axis and velocity update frequencies?
Happy machining , Jeff Birt
 

Offline Jeff_Birt

*
  •  1,107 1,107
    • View Profile
    • Soigeneris
Re: Smooth Stepper Times Out.
« Reply #3 on: August 18, 2009, 09:07:31 AM »
I've not seen the exact behavior your describing. It could be that the SS is picking up noise from the machine. Is the spindle motor powered when you have this problem? I have had some PC's that had issues with the built in USB ports being flaky with any device that had high data rates like hard drives, flash drives, etc. My shop PC is one old one that I have had the problem with. I have an add-on PCI USB 2.0 card that I bought years ago for it that solved the problem. I'll be interested to see what you find with the new PC.

Oh! Don't forget to turn off the power savings stuff for your USB stuff. Go into device manager and right click on each USB port/hub and if you see a 'Power' tab uncheck the box that lets Windows power it down.
Happy machining , Jeff Birt
 
Re: Smooth Stepper Times Out.
« Reply #4 on: August 18, 2009, 10:32:09 AM »
Can you guys recover with a click of the reset to get SS control back? I cant even get it to do that, i have to restart mach.

Offline RICH

*
  • *
  •  7,419 7,419
    • View Profile
Re: Smooth Stepper Times Out.
« Reply #5 on: August 18, 2009, 11:42:11 AM »
Just a clarification on my end.
Never had the SS time out / lose communication on me when running a program, never had it lose communication when using CopyCat, along with a video camera and also XBOX 360 and then into Mach.

I have found that it will loose communication, and a reset dosen't work requiring to me to go out of Mach.......................when I do a screen shot when dry running something.  
Let me put this into perspective, namely I am bouncing back and forth between a word processor, lazyCam, Mach, screen capture utiilities. etc! This is way out of the norm and you would / shouldn't ever, never be doing any of that that kind of stuff when actually machining.  

So my bad experiences are nill or yet to find a combination that did it,
Rich