Hello Guest it is September 15, 2019, 01:40:59 PM

Author Topic: G-Code rendering improperly  (Read 3792 times)

0 Members and 1 Guest are viewing this topic.

G-Code rendering improperly
« on: August 12, 2009, 10:54:35 PM »
Hi All,

I tried to post this in the bugs section but it considered me a "spammer". Maybe because my text had links in it? ... Anyway

If you use this profile: http://www.c-horsesoftware.com/mach3issue/FireballV90.xml

It incorrectly renders this job: http://www.c-horsesoftware.com/mach3issue/JRC_faceplate.dnc

Here's what it should look like (this is from DeskCNC):



Here's what it looks like on Mach3:



It renders properly when I use the Mill profile that comes with the software. Any idea what's causing it?


-- Fred
« Last Edit: August 12, 2009, 10:56:58 PM by C-Horse »

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: G-Code rendering improperly
« Reply #1 on: August 12, 2009, 11:04:41 PM »
Maybe the IJ mode?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: G-Code rendering improperly
« Reply #2 on: August 12, 2009, 11:09:01 PM »
Hi, Fred

Post the dxf file we'll look at it, May just be a setting in Mach3 like a g90.1 or g91.1 IJ's in abs inc mode set incorrect or XY XZ plane setting.

You  need preamble setting's in the top of your G code to configure Mach to the "Proper State" to run/display the Code properly.

Put a G91.1 in the top of your G code, Look's good hear, Try the att. G code file.

Chip  
« Last Edit: August 12, 2009, 11:33:41 PM by Chip »
Re: G-Code rendering improperly
« Reply #3 on: August 12, 2009, 11:58:42 PM »
Thanks for all your responses folks.

There's a link in my initial post to the actual G-Code file if you'd like to investigate. It's the JRC_faceplate.dnc link.

I re-created the Fireball Profile and it displays properly now (as I suspected it would since it displays properly with the Mill sample profile). It's more than likely something I did to the config settings of my initial Fireball profile... I just can't figure out what.

Thanks again for your feedback.

-- Fred
Re: G-Code rendering improperly
« Reply #4 on: August 13, 2009, 12:08:59 AM »
I simply created a new profile, entered my soft limits, ports, motor setup, etc. And the exact same file now renders properly... but I sure would like to know how I made it happen in the first place.

To reproduce the problem you'll have to download the XML from the link in my first post. Load the FireballV90 profile at startup or you won't see the problem. But, again, the problem is gone so I'd hate to waste too much of anyone's time. If you do figure it out, please post. If I figure it out I'll do the same.



-- Fred


Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: G-Code rendering improperly
« Reply #5 on: August 13, 2009, 12:20:48 AM »
Hi, Fred

I did find your G code file, It was a Preamble setting and posted your G code with a G91.1 in it in my post above.

Glad you got it sorted out, Chip
Re: G-Code rendering improperly
« Reply #6 on: August 13, 2009, 12:52:33 AM »
Thanks Chip

I missed the attachments when I read it innitially.

-- Fred