Hello Guest it is August 13, 2020, 08:05:37 AM

Author Topic: Machturn  (Read 3531 times)

0 Members and 1 Guest are viewing this topic.

Machturn
« on: August 07, 2009, 03:29:22 PM »
I have a pipe 25mm in diameter with an 8mm diameter hole. I want to bore (or internally turn as VisualTurn puts it) the interior to 12.5mm in diameter. In other words I want to enlarge the hole 4.5 mm in diameter. I created the stock and final workpiece dimensions in VisualTurn and created the gcode then postprocessed the gcode through their Mach3 postprocessor. When I go into MachTurn the code is giving me external turning and is in inch mode. What can I do?

G18 G40 G49 G17 G90 G80
G20
(Turn Roughing)
M3
T10
G54
G50 S6067
G97 S1200 M03
G0 Z0.0917
X0.0630 Y0.0000
G71 F0.04
G1 X0.0658
G71 F0.08
G71 F0.04
X0.1215 Z0.0360
X0.1772 Z-0.0197
G71 F0.08
Z-2.9409
G71 F0.16
X0.1493 Z-2.9131
Z-2.7950
G71 F0.04
X0.0757
G0 Z0.0917
G71 F0.04
G1 X0.1052
G71 F0.08
G71 F0.04
X0.1609 Z0.0360
X0.2165 Z-0.0197
G71 F0.08
Z-2.9409
G71 F0.16
X0.1887 Z-2.9131
Z-2.7950
G71 F0.04
X0.1150
G0 Z0.0917
G71 F0.04
G1 X0.1446
G71 F0.08
G71 F0.04
X0.2002 Z0.0360
X0.2559 Z-0.0197
G71 F0.08
Z-2.9409
G71 F0.16
X0.2281 Z-2.9131
Z-2.7950
G71 F0.04
X0.1544
G0 Z0.0917
G71 F0.04
G1 X0.1839
G71 F0.08
G71 F0.04
X0.2396 Z0.0360
X0.2953 Z-0.0197
G71 F0.08
Z-2.9409
G71 F0.16
X0.2674 Z-2.9131
Z-2.7950
G71 F0.04
X0.1898
G0 Z0.0917
G71 F0.04
G1 X0.2194
G71 F0.08
G71 F0.04
X0.2750 Z0.0360
X0.3307 Z-0.0197
G71 F0.08
Z-2.9409
G71 F0.16
X0.3029 Z-2.9131
Z-2.7950
G71 F0.04
X0.1898
G0 Z0.0917
G71 F0.04
G1 X0.2194
G71 F0.08
G71 F0.04
X0.2750 Z0.0360
X0.3307 Z-0.0197
G71 F0.08
Z-2.9409
X0.1772
G71 F0.16
X0.1493 Z-2.9131
Z-2.7950
G0
X0.0630
G0 Z0.1
M5
M30


Please ignore the speed and feeds. I can always adjust those later. My problem seems to be that I can't get Machturn in mm mode and it doesn't understand the stock that I am using.
« Last Edit: August 07, 2009, 03:32:18 PM by kdoney »

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Machturn
« Reply #1 on: August 07, 2009, 03:49:19 PM »
This is not a Mach problem, it is a PostProcessor issue. You will need to find or make a metric postprocessor for your CAM.

Hood

Offline RICH

*
  • *
  •  7,411 7,411
    • View Profile
Re: Machturn
« Reply #2 on: August 07, 2009, 07:01:51 PM »
There may be an seperate post processor, one for external and one for internal, for your software. That's the case with Dolphin if i remember, for example.
Don't use Visual Turn, but, it i would quess you need to define that it's an internal or external lathe operation.
The pathing will be different.

RICH
Re: Machturn
« Reply #3 on: August 07, 2009, 11:14:53 PM »
try this program it will convert your inch output to mm


http://tinyurl.com/3omytt

Michel
« Last Edit: August 07, 2009, 11:16:57 PM by Michel S. »
Re: Machturn
« Reply #4 on: August 08, 2009, 10:04:48 AM »
i know it is not solving your problem, but for such a simple operation, nothing can beat the wizzards built into mach3. i did a test with visual turn and had the same issue with the software always revert to metric when i want inch. if you click on the "units" menu you can see in the status bar the units you in. but has hood mentions,g code is done in the post processor. visual turn has a post processor editor where you can change the settings to metric.