Hello Guest it is August 22, 2019, 12:22:11 PM

Author Topic: apparent loss steps?  (Read 4207 times)

0 Members and 1 Guest are viewing this topic.

apparent loss steps?
« on: July 29, 2009, 10:47:09 AM »
Hi all, I am new to CNC and trying to work out the bugs of my new DIY kit from BuildYourCNC.  I am not sure the make of the controller or breakout board but the steppers are 425oz motors and lead screws are 4tpi.  I have done the math and have the steps set at 12800 for 1/16 and seems correct.  I am using Aspire2 for my models.
While trying to cut a finish pass with 1/8" ball nose on an aspire example file the z axis is off by 0.330 after cutting about 8" of the model.  I changed the "uS" setting to 5 and changed to 1/4 stepping (also did the math for changed stepping)... this resulted in being off 0.330 in less than 2".  When I say off by 0.330 it is cutting too deep.  Guess I should have mentioned I am running Mach3.
Re: apparent loss steps?
« Reply #1 on: July 29, 2009, 02:41:27 PM »
do you mean that your z axis is moving while doing a cut in the x-y plane? or is it a 3d cut?
Re: apparent loss steps?
« Reply #2 on: July 29, 2009, 03:41:31 PM »
It is a 3d cut, with an overall max cut of -0.605 in z.  But after finishing just over half the lines z is off by -0.330.
Re: apparent loss steps?
« Reply #3 on: July 29, 2009, 03:56:04 PM »
put a dial indicator on your z axis and do some g1 moves up and down to compare the reading on your screen and the indicator. start at a very slow feed, then increase the fedd to find the point where the motor starts loosingsteps. if you where loosing steps, you would probably end up not deep enough instead of too deep.  unless your column is too heavy and the motor can lower it but can'raise it.

simon
Re: apparent loss steps?
« Reply #4 on: August 09, 2009, 02:55:29 PM »
The motors and controllers are Keling, after reviewing their documentation Sherline 1/2 pulse mode is the culprit.  However this is causing another problem.  When checked the y axis moves in the same direction no matter what direction told.

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: apparent loss steps?
« Reply #5 on: August 09, 2009, 05:19:37 PM »
Hi, Danny

Set your Active Low setting to the same "State" as your Z,X in Ports & Pins, Motor Outputs page, See if that fixes it.

If there all the same (As thay should be), Then you may have a bad connection on the Y Dir Pin.

If your axis runs backwards, Use Home & Limits page "Reversed" box to change the Direction (This is the proper way to change it).

Hope this Helps, Chip

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: apparent loss steps?
« Reply #6 on: August 09, 2009, 06:41:50 PM »
If your drives have a dip switch for Step/Dir or CW/CWW operation then try it the other way. I have just set up a similar drive as a secondary spindle on the coil winder and I found that the documentation seems to be wrong, if I had it in the position that is supposed to be Step/Dir then it would only rotate one way. I set it to what is supposed to be CW/CWW operation and it is fine.
Hood
Re: apparent loss steps?
« Reply #7 on: August 09, 2009, 07:22:04 PM »
OK... not what you guys directly suggested... but it lead me to the answer.  Mach3 came with the a axis set to pins 5 and 9.... must have been intefering.  When I set them to 0,0... problems went away.  Now I just hope the Sherline 1/2 pulse mode fixes the dropped steps problem.
Re: apparent loss steps?
« Reply #8 on: August 12, 2009, 10:47:58 AM »
Howdy guys and thanks for the support.  I have read everything I can find about micro stepping and really dont understand the results I am seeing.  I have a Keling 36v power supply and controller and 425ozin motors.  I have the controllers set to 3amps. I originally setup my machine with 1/16 stepping and was losing .330 in z while cutting a 3d sample model from Aspire2 (vectric).  I have ensured enhanced pulsing is selected, I have the sherline 1/2 pulse mode selected.  I changed the stepping to 1/2 and my z was off by .500 within 5 minutes of running.  So I went to the other extreme and set it to 1/64.  I was able to finish the model (4"x4") and was off by 0.085 when done.  I have no more selections for microstepping, even though I dont understand why more microsteps would reduce loss steps, how do I get this dialed in.  I have the x and y axis set at 30in/min with acc set to 2.  I have the z axis set to 15 in/min with acc set to 4.  Assuming these are the only values left to play with, which way do I go?

Offline simpson36

*
  •  1,374 1,374
    • View Profile
Re: apparent loss steps?
« Reply #9 on: August 13, 2009, 02:56:41 AM »
Starting with the assumption that you have already checked things like the slides binding and any other mechanical causes, you should look into what speed is the pulse stream output set to. It is under config>ports and pins.

With high microstepping, you probably have a huge number of steps per unit. If you can, set the microstepping off (and reset Mach appropriately) and see if the problem goes away.

Mach needs lots of pulse speed to be able to run all three axis simultaneously, so you will need a high pulse stream speed with a lot of microstepping dialed in.