Hello Guest it is October 21, 2019, 01:44:11 AM

Author Topic: step rate  (Read 3578 times)

0 Members and 1 Guest are viewing this topic.

step rate
« on: July 18, 2009, 01:12:37 PM »
How do you change the tep rate in Mach3?

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: step rate
« Reply #1 on: July 18, 2009, 02:41:06 PM »
What are you meaning by the step rate?
Hood
Re: step rate
« Reply #2 on: July 18, 2009, 03:53:23 PM »
The X-axis stepper is stalling, another forum told me to reduce the step rate and I'm not sure how to do it.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: step rate
« Reply #3 on: July 18, 2009, 03:55:04 PM »
If a motor is stalling then you want to reduce the Velocity or Accelleration, you will find them on the motor tuning page from Config menu. Remember to save axis settings after you have changed them.
Hood
Re: step rate
« Reply #4 on: July 18, 2009, 04:03:06 PM »
I have tried many different combinations and still have a stalling issue. There is no mechanical prolems, and the stalling happens a random times during a run. Sometimes as long as thirty minues in.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: step rate
« Reply #5 on: July 18, 2009, 04:17:23 PM »
what pulse width do you have set? What make of drives do you have? What breakout board do you have? What kernel speed are you using?
Hood
Re: step rate
« Reply #6 on: July 18, 2009, 04:24:21 PM »
Pulse with 3, kernal speed 25000, HbbyCN boad with nema23 305oz motors. Thanks for taking the time to help.

cb

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: step rate
« Reply #7 on: July 18, 2009, 04:27:15 PM »
not familiar with the HobbyCNC stuff but try swapping drive between X and Y if it is possible, also make sure enhanced pulsing is enabled on General config page.
Hood

Offline simpson36

*
  •  1,374 1,374
    • View Profile
Re: step rate
« Reply #8 on: July 21, 2009, 07:05:26 AM »
What kind of computer and OS are you using?

You might try opening the task manager and clicking the performance tab to see how much CPU you are using. If it pegs, the motors will stall. Even reasonably powerful computers can have so many background tasks running that Machruns on leftovers.

Stop any antivirus/antispyware software while running Mach.

Make sure you do not have any printer drivers installed in the computer. That can also stall the motors when the driver polls the port.

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: step rate
« Reply #9 on: July 21, 2009, 09:05:17 AM »
It may just be resonance. You might try making a damper if yo have dual shaft motors. There's a long thread at CNC Zone on it.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html