Hello Guest it is June 18, 2019, 01:52:29 PM

Author Topic: emergency mode forever  (Read 4235 times)

0 Members and 1 Guest are viewing this topic.

emergency mode forever
« on: August 23, 2006, 10:26:35 AM »
Trying to learn mach3 i have 2 pc, run ok in the first one, but i have a problem in the other, the reset button flashs and says the emergency mode is active.
Tryed to unmark the estop sign in the config/port&pins/input signals window, but not a solution.
maybe a limits problem, my cnc device is not conected to the pc, and in a confcheck its all ok exept this:
/////////Motor Settings - Enabled Motors only are Checked/////////////////////!.

 A motor Step pin is set to a port other than 1 or 2, this is probably an error..
 A motor Direction pin is set to a port other than 1 or 2, this is probably an error..
 A motor Step pin is set to a port other than 1 or 2, this is probably an error..
 A motor Direction pin is set to a port other than 1 or 2, this is probably an error..
 A motor Step pin is set to a port other than 1 or 2, this is probably an error..
 A motor Direction pin is set to a port other than 1 or 2, this is probably an error..

how can i desactivate the emergency mode?
please help.

Offline Chip

*
  • *
  •  2,057 2,057
  • Gainesville Florida USA
    • View Profile
Re: emergency mode forever
« Reply #1 on: August 23, 2006, 12:39:22 PM »
Hi, Arqarod

The E-stop setting need's to be changed depending on which version your using, in later ver. of mach3  check the Enabled, green check then check the Active Low Green also, hit apply.

If that doesn't work just put 0's in the Port # and Pin Number coll-um for E-stop, some older versions you need to do it that way.

Hope this Helps Chip
Re: emergency mode forever
« Reply #2 on: October 20, 2006, 02:12:01 PM »
I am trying to set up homing and I cant get rid of the e stop definition on the Ports and Pins >Inputs:screen.  If I scroll down and un-check the e-stop enable (set it to red) then hit Apply and get out of the menue, then try to reference and the machine goes into Emergency mode, so then I go back and the e-stop is green again.  It will not let me disable the e-stop.  Can I use Port 1, Pin 1 for a limit input?  Even with the port number and pin number set to 0, as soon as I trip that input that I am using for a limit it re-writes the e-stop definition for e-stop "enabled" set for port 1 pin 1.

Can I use Port 1, Pin 1 for a limit?  How?
« Last Edit: October 20, 2006, 02:14:06 PM by Halfnutz »

Hood

*
Re: emergency mode forever
« Reply #3 on: October 20, 2006, 02:41:47 PM »
What to do is change the  Active Low setting for the E Stop, that should clear your problem.
Hood
Re: emergency mode forever
« Reply #4 on: October 20, 2006, 06:34:59 PM »
OK, I geusse thats it, thanks.  I have no idea why it works that way, but it seems to solve the problem .  Thanks again...