Hello Guest it is May 22, 2019, 01:14:58 PM

Author Topic: leadscrew pitch error  (Read 5515 times)

0 Members and 1 Guest are viewing this topic.

leadscrew pitch error
« on: July 01, 2009, 05:03:00 PM »
hi all, I recently finished rebuilding an emco5 pc lathe.
I am now working through the configuration of the software and testing the axis and motors / tuning etc.  The traverse I have is 50mm (2") on the X and 300 on the Z (12", for all those yankees  8)

I have a pitch error on my lead screw (the Z axis). I gauged it over 200mm (8") .  I gauged by moving the leadscrew in one direction only and using a 'setting standard' between the carriage and limit switch on the Z, i.e; a  200mm mic setting piece.

I know the mic setting piece is good as i cross referenced it with a couple of different mics, hot day aswell! 27 degrees C' in my workshop, (i started to sweat  >:( )     but that didnt affect the setting piece or mics, theoretically they may have all three items  expanded by the same amount, but I doubt it they all read 200 within 0.01.     The limit switch is also very repeatable to within 0.01mm  ( i tested it over and over with homing (50% rapids), manual jogging 0.01 steps)  i'll also check the error early in the morning when its cool, just to be a fanatic  ;D

I have 0.17mm pitch error over 200mm,  I used to get that same pitch error from 600mm travel off an old 'well used' bridgeport mill, go bridgeport!.

I am using a 2.5mm pitched 8mm dia ballscrew (o.e.m, tiny aint it) , geared with a 2.5:1 timing pulley ratio, and 800 step/rev config in quarter step mode.     it gives me a resolution of 1.2micron/step and a max rapid of 1.25m/min before the motors bum out.

i'm never going to get micron accuracy over 200mm, but 0.05/0.1mm would be more better at least!.

I got two choices i think, first is to put in a new quality ballscew and nut, and new bearings either end of the screw and hope it works as the box says,  or maybe configure mach to account for the pitch error,  i have been reading a few posts about screw mapping but have not yet figured out how to carry out this physically

all I have to go on is a setting standard and blame the lead screw  :)  easy to blame something,

if i could just account for that error i could live with it ,  anyone got any help?, thanks!, adam.


« Last Edit: July 01, 2009, 05:07:49 PM by hutchison »

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: leadscrew pitch error
« Reply #1 on: July 01, 2009, 05:23:27 PM »
What is the pitch error over smaller distances? If it is linear then you could just adjust the steps per unit to account  for the error. Curious, are you using the original drives and motors?
Hood

Offline RICH

*
  • *
  •  7,331 7,331
    • View Profile
Re: leadscrew pitch error
« Reply #2 on: July 01, 2009, 09:33:16 PM »
HUTCHISON,
If it was linear as Hood said just change the steps per unit to make it right. If it is not linear, is there a sweet spot that you would normaly work in? If you replace with rolled ball screws some of them are like .003" / foot , which granted is half of what you have, but they return in the opposite direction at that linear rate. So read the spec's carefully on the ball screws.
This is a good example of where you change the steps per unit to something other than what is calculated.
RICH
Re: leadscrew pitch error
« Reply #3 on: July 02, 2009, 06:18:30 PM »
ok guys thanks alot for the help, i understand by changing the steps per unit , if it was a linear error , would be the perfect solution and a correct one.  hood i have changed all the electronics and motors for new kit.

I did how-ever find the problem this morning,...   i got in the shop at 8, 21 degrees allready , perfect i guess except i knew i was going to cook later!.   And proceeded to  chart all the points of the screw, i thought i would use standards and slips to give me a accurate map etc.   I started out with a 200mm standard  just to see if it was the same as yesterday ,   200.13 it showed..  hmm thats different allready i thought.  , i went straight down to a 100mm = 100.13 ..    thats not looking good i thought i was hoping for half of the error not equal, I had now suspected either i had a completely shot screw on one half or something else not to do with the standards or the lead screw was happening.  I then tried a 20mm slip , guess what..  20.13 (or as near as etc ),  now that really got my goat!!, i wandered around for a while scratching ,  i then tried a 1.3mm slip..  once again 1.43mm displayed in the dro, at that point I was suspecting the error in my screw was not pitch error.

i removed the last 1.3mm slip and jogged the axis upto home, the dro displayed  bang on zero give or take a few microns.   how about that (laughs!) so..  i was excited as i knew i had a good screw  ;D  ..  but mystified why the error went all the way back upto home..   and started looking at my home switch set-up, which is rock solid mounted, and i did use some branded micro switches (saia burgess etc) so trying to limit the can of worms!.   after a while I figured out  why i was getting a bum reading..   well...  the burgess micro switch had a domed front actuator,  and me in my infinte mechanical wisdom also put on a domed face to my rod stop..  nowt wrong with that i thought it would minimise the chance of a chip settling on the stop right....  So the reason i had this funny error..  the two domes were not dead inline, infact one was nearly two mm off centre line to the other,  thus..  you can set zero and repeat zero all day long on a diagonal, put a slip gauge or setting rod between the two, you add that initial error of diagonal contact to the gauge length on the horizontal.  its not rocket science is it! its one of those things that gets you when you think youve come along way, and trip up and fall on your face  ;D

my trouble was solved by swiflty removing the rod stop and facing it flat.  

cheers lads for the help, im going to go and get back in the box   :)

« Last Edit: July 02, 2009, 06:24:00 PM by hutchison »