Hello Guest it is July 21, 2019, 05:40:39 AM

Author Topic: What are the OEM Code of LEDs used in "Port 1 Pins current State"?  (Read 6337 times)

0 Members and 1 Guest are viewing this topic.

Hello to all. Want to know the correspondence between the number of pins of LPT1 with the OEM Code (Led) 139 to 160. Thanks in advance. Giordano

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: What are the OEM Code of LEDs used in "Port 1 Pins current State"?
« Reply #1 on: June 24, 2009, 06:43:18 PM »
137 - 160

Hood
Re: What are the OEM Code of LEDs used in "Port 1 Pins current State"?
« Reply #2 on: June 24, 2009, 06:51:13 PM »
Hello Hood. Thanks for your reply. Let me explain better. For example, the LED pin 15 of LPT1 is OEM Code 140. Thank you.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: What are the OEM Code of LEDs used in "Port 1 Pins current State"?
« Reply #3 on: June 24, 2009, 06:54:50 PM »
Sorry, late here and wasnt reading properly.
 Well afraid I do not have a clue, never worked out what they represent, then again I have never really tried to ;D
Hood

Offline Chip

*
  • *
  •  2,057 2,057
  • Gainesville Florida USA
    • View Profile
Re: What are the OEM Code of LEDs used in "Port 1 Pins current State"?
« Reply #4 on: June 24, 2009, 09:45:01 PM »
Hi, Giordano

The only one's defined/that work are are Input pin's 10, 11, 12, 13 & 15, As far as I know.

Chip
Re: What are the OEM Code of LEDs used in "Port 1 Pins current State"?
« Reply #5 on: June 25, 2009, 06:33:45 AM »
Hello, Chip. Making a new screenset Italian and wanted to monitor the activities of LPT1. Thank you. Giordano

Offline Chip

*
  • *
  •  2,057 2,057
  • Gainesville Florida USA
    • View Profile
Re: What are the OEM Code of LEDs used in "Port 1 Pins current State"?
« Reply #6 on: June 25, 2009, 03:22:28 PM »
Hi, Giordano

I did one like this, It would be nice if they were all working.

Chip
Re: What are the OEM Code of LEDs used in "Port 1 Pins current State"?
« Reply #7 on: June 26, 2009, 08:14:34 AM »
Hello, Chip. Very well done. Do you have a particular version or you have modified the original screen for Mach3? In my version, the 3,042,020 pins are not numbered and inputs 10,11,12,13 and 15 are arranged differently. You could tell me what the Code of OEM led each pin from n. 1 to n. 25 or, better yet, send me a copy of your screen? Regards. Giordano

Offline Chip

*
  • *
  •  2,057 2,057
  • Gainesville Florida USA
    • View Profile
Re: What are the OEM Code of LEDs used in "Port 1 Pins current State"?
« Reply #8 on: June 27, 2009, 08:29:20 PM »
Hi, Giordano

It's the standard 1024 screen set, I used a copy of it and "Screen4" to move the led's around and added items I wanted.

Hears 2 work-in  progress Screen set's I'm working to help "Mostly" new Users figure out what "Mode" Mach is in, 1 for Mill, 1 for Lathe, Both have a pop-out lathe Pendent at this point, You need to install the bitmaps in C:\Mach3\Bitmaps\Millbitmaps folder.

Have Fun, Chip
Re: What are the OEM Code of LEDs used in "Port 1 Pins current State"?
« Reply #9 on: June 28, 2009, 02:10:39 PM »
Hello, Chip. I you were a great help. Thank you very much. Regards, Giordano.