Hello Guest it is October 18, 2019, 06:06:12 AM

Author Topic: Enable 1-6 Signals. How to innitialize?  (Read 2248 times)

0 Members and 1 Guest are viewing this topic.

Enable 1-6 Signals. How to innitialize?
« on: June 17, 2009, 06:19:07 AM »
The enable 1-6 Signals are activated when pressing the Reset button.
How to make them not to be activated when Reseting?
Are these outputs being deactivated by the program (by itself) for any reason,
or only by a brain or a button?
If you have any idea, please share it...

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Enable 1-6 Signals. How to innitialize?
« Reply #1 on: June 17, 2009, 01:52:04 PM »
Enables are meant to send a signal to your hardware to say Mach is ready and are used to make the hardware ready. If Mach is in Reset then Mach is not ready so the Enables are switched off.
 What is the reason you are wishing the enables not to be switched off when Reset is active?
Hood
Re: Enable 1-6 Signals. How to innitialize?
« Reply #2 on: June 18, 2009, 01:43:54 AM »
I just want my drives to be dissabled when mach starts.
Then, with a button i will enable them before moving.

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Enable 1-6 Signals. How to innitialize?
« Reply #3 on: June 18, 2009, 02:52:30 AM »
That is more or less what the Enable does with the exception that the enables are then taken away when Mach is again put into reset. That is a normal safety procedure as normally you do not want drives enabled when Mach is in reset.
 It could probably be done with a seperate button using a Brain if you preferred.
Hood