Hello Guest it is October 23, 2019, 01:55:34 AM

Author Topic: Using more than one cutter  (Read 2404 times)

0 Members and 1 Guest are viewing this topic.

Using more than one cutter
« on: June 01, 2009, 05:31:57 PM »
I needed to drill some holes in a part after machining a form on to it.  I just wanted to centre drill the hole positions to pick them up for drilling later on.  Being lazy instead of working out how to use the tool table I just did two separate programs, one for the machining and one for the centre drilling.  It's a manual tool change, so no advantage in having it all in one program anyway.  I ran the machining, then when the program finished I changed the tool, reset the Z to suit the new tool, loaded the next program and ran the centre drilling program.  But the centre drill was out of position by about 1mm in X.  I've obviously missed a crucial step in the way I did this -can anyone tell me what that was?  I did notice that the original form was cut with tool 0, and the centre drill was tool 1 (they were programmed from one cam set up and it just incremented the tool number automatically), would this have made any difference.  I have had accuracy issues in the past, but I'm happy the machine is accurate now, as the form was cut in over 60 passes all of which lined up perfectly -I just centre drilled in the wrong place.  Obviously lost position somehow when changing tool and re-setting the Z.

Regards
Kevin

Offline RICH

*
  • *
  •  7,368 7,368
    • View Profile
Re: Using more than one cutter
« Reply #1 on: June 01, 2009, 08:31:48 PM »
Kevin,
Was there any difference in the part zero location between the two programs?
Just a quess!
RICH
Re: Using more than one cutter
« Reply #2 on: June 01, 2009, 09:13:27 PM »
No, it was all programmed at the same time -from the same datum.  But I've obviously done something that has lost/changed the datum on the machine when changing the tool -I just don't know what yet.

Regards
Kevin
Re: Using more than one cutter
« Reply #3 on: June 02, 2009, 12:23:11 AM »
AAAAAARRGH!!!!!  Careful measurement of the part reveals the true problem.  It measures 0.3mm less at the top than at the bottom, so I'm still losing steps and getting a gradual drift of the machine position.  The centre drill is 0.6mm different from side to side (the 0.3mm out of position indicated by the part being smaller at the top).  I'm now completely back to square 1.  Will re-post to a new topic, with the correct question -back to accuracy and step loss.