Hello Guest it is August 19, 2019, 09:43:01 PM

Author Topic: Cut2D and Z-Axis  (Read 4094 times)

0 Members and 1 Guest are viewing this topic.

Cut2D and Z-Axis
« on: May 17, 2009, 03:11:57 AM »
I'm using a Zenbot, Mach 3 and Cut2D. Hardware is working fine.  I would like 0,0,0 (home) to be with tool (Z) at highest. This means max depth is at -4.00 inches.  My manually coded programs work as expected.
However, when I create my toolpath in Cut2D, the lowest point is zero and I can not set it to a negative number. When the G-Code is generated, all the Z references are from 0 to +4.00 instead of -4.00 to 0. Am I forced to set my zero for the Mach3 at the tabletop and give up homing ?

Or is it possible to home to a positive number? I'm sure other people are using Mach3 and Cut2D - how are you handling this?

Thanks.

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Cut2D and Z-Axis
« Reply #1 on: May 17, 2009, 03:41:46 AM »
Dont know anything about Cut2D but kind of sounds like you may be using a plasma post processor.
Hood
Re: Cut2D and Z-Axis
« Reply #2 on: May 17, 2009, 04:04:22 AM »
I am using the Mach2/3 post processor.

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Cut2D and Z-Axis
« Reply #3 on: May 17, 2009, 06:59:43 AM »
What most people do, is, in Cut 2D, set the top of your part to Z=0, and zero the Z axis to the top of your part.

There is another way. In the Homing/Limits screen, set the Home Offset for the Z axis to 4. That way, the table will be at Z=0 and the home position will be Z=4. Then, in Cut 2D, set Z=0 to the bottom of your part. The problem with this method is that if your part thickness is not exactly what it's supposed to be, your cut depths will be off by that same amount.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline budman68

*
  • *
  •  2,360 2,360
    • View Profile
Re: Cut2D and Z-Axis
« Reply #4 on: May 17, 2009, 08:37:15 AM »
What most people do, is, in Cut 2D, set the top of your part to Z=0, and zero the Z axis to the top of your part.

That's the way I set it up.  :)

Dave
----------------------------------------------------------------------
Just because I'm a Global Moderator, don't assume that I know anything !

Dave->    ;)

vmax549

*
Re: Cut2D and Z-Axis
« Reply #5 on: May 17, 2009, 04:20:25 PM »
Sounds like the POST needs to be fixed (;-) OR you are setting the parameters on the drawing incorrectly.

(;-)TP
Re: Cut2D and Z-Axis
« Reply #6 on: May 17, 2009, 09:16:20 PM »
Thanks for your input.

I'm making progress with the recommendation from Ger21.

Ideally I'd like to have the Vectric post processor make adjustments to the Z-axis numbers but I don't know if that is possible. I can do it manually for simple files so I know it would work. I'm still waiting on my acceptance to the Vectric forum so I can ask that question