Hello Guest it is April 25, 2019, 08:47:48 PM

Author Topic: frustrated can somebody help me set mach up?  (Read 3904 times)

0 Members and 1 Guest are viewing this topic.

frustrated can somebody help me set mach up?
« on: May 09, 2009, 03:56:34 PM »
hey all!

I have a almost converted sieg x3 mill with g203v's, keling motors, candcnc breakout board with modular gecko mounitngs, dolphin cad/cam and mach 3(er still need to buy mach lol but will asap).

Im getting frustrated with the process- i feel like im in a holding pattern, and have been for the past 4 weeks or so. I have read the first 81 pages of the "using mach3" pdf and found it very helpful, but i still just can't figure out what i need to do so i can start making parts. I think they are all very simple fixes so i just want to post here- i am i high school student and spent way to much money on this project :( and need the machine back up and running so i can make back some of my losses.

First problem-
Homing!
I want the X and Y to read 0 when they hit the home switches, and the z axis 0 should be the table correct? then something like 12" or so up from that?
Well my 0 is in the middle of the x,y, and z so when i say for example g28 x0 it doesn't take it home. So then i jogged it till it touched the home switch and in the home settings, where it says "g28 location" i typed in the setting on the dro (for example- like -4.28" or something) then in the MDI when i say g28 x0 it goes to the x home and the x home switch lights on on my candcnc bob.

BUT: it doesn't do as mach says it does (once again, im sure its MY fault), where it goes till it closes the switch then backs off till its just off the switch. it just sits there.

I would imagine it would make setting up work a HELL of a lot easier if the home was at 0,0,(whatever for z- im not sure because im new at this).

So wrapping up question 1: How do set my HOME positions to 0,0, and NOT a random number for Z, and why doesn't it back off the home like it should?

I can take a "ok" quality video of it and the settings to help you guys know what i mean if needed.

Second question: The x axis stepper has been acting sporatically. Nothing changed- it worked great for while but then yesterday, no matter what direction you tell it to move it it Jumps in the same direction (alway away from the home switch), then randomly jumps back the other way ( while still pressing the same direction key) then stops moving. if i re-start the computer then this process repeats itself.

I would greatly appreciate your help guys.

Thanks so much!

Reed

Offline Chaoticone

*
  • *
  •  5,472 5,472
  • Precision Chaos
    • View Profile
Re: frustrated can somebody help me set mach up?
« Reply #1 on: May 09, 2009, 04:26:25 PM »
Reed, I have sent you a personal message.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: frustrated can somebody help me set mach up?
« Reply #2 on: May 10, 2009, 06:42:21 PM »
thanks mate-


Btw i had a total epiphany yesterday. my x axis has been acting up since i installed the home switches which are pretty close to the x axis stepper- im pretty positive thats whats going on. im using shielded wires but ill... idk, try to get some metal tape or something and some metal wire loom
Re: frustrated can somebody help me set mach up?
« Reply #3 on: July 11, 2013, 03:13:16 PM »
Am having same issue but different system.
I am new so forgive me if I excluded any details. I using DMM servo with dmm BB B4250-8B on XP system, Parallel port add 378, limits switches in working order. Can't get all axis motors to move in Mach3 but they do move when using Dmm tuning cable. I follow mach3 installation instruction closely and input pins&ports per BB instructions. What else can I change to get they move?

Appreciate any inputs

Offline Hood

*
  •  25,785 25,785
  • Carnoustie, Scotland
    • View Profile
Re: frustrated can somebody help me set mach up?
« Reply #4 on: July 12, 2013, 02:43:00 PM »
attach your xml and I will see if anything is wrong.
Hood
Re: frustrated can somebody help me set mach up?
« Reply #5 on: July 12, 2013, 03:23:43 PM »
Hi Hood

Unable to attach XML file from iPhone, no Internet on PC, but just reload XML file DMM Tech and now the EStop external requested unable to reset. I then change estop port# to 0 from 1 get it reset but still not ruining. Estop is wired normally closed (In and ground shorted Vout unused).

Thanks

Offline Hood

*
  •  25,785 25,785
  • Carnoustie, Scotland
    • View Profile
Re: frustrated can somebody help me set mach up?
« Reply #6 on: July 12, 2013, 04:37:36 PM »
Afraid without seeing the xml I would just be guessing at what could be wrong.
Hood