Hello Guest it is October 28, 2021, 12:21:22 AM

Author Topic: Z axis 0  (Read 6170 times)

0 Members and 1 Guest are viewing this topic.

Z axis 0
« on: May 02, 2009, 10:42:51 AM »
I looked but can't find this in the tutorials. When I set Z 0, the DRO flashes 0.375 then sets 0. If I only regen 1 time, the z axis cuts air. If I regen 3-4 times it works like it should. One thing I noticed is the DRO is not bold like the rest of them. I'm sure it's something simple, but I'm stumped.

Jim

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Z axis 0
« Reply #1 on: May 02, 2009, 02:10:45 PM »
please attach the xml for the profile you use. If its standard Mill profile it will be called Mach3Mill.xml and you will find it in the Mach3 folder. You will need to rename it to attach to the forum, suggest you call it jhop.xml

Hood

Offline alenz

*
  •  137 137
    • View Profile
Re: Z axis 0
« Reply #2 on: May 02, 2009, 10:46:58 PM »
I looked but can't find this in the tutorials. When I set Z 0, the DRO flashes 0.375 then sets 0. If I only regen 1 time, the z axis cuts air. If I regen 3-4 times it works like it should. One thing I noticed is the DRO is not bold like the rest of them. I'm sure it's something simple, but I'm stumped.

Jim

Hi Jim,
The odd DRO display isn’t likely related to your problem. (I see one of the pros has offered to help you with that, take him up on it.)  That’s over my head, but I have dealt with the odd display issue.
The DRO font is determined by the height of the box. The font adjusts to fit the height and at certain breakpoints will go from regular to bold before jumping to the next larger size. On some machines, (mine included), if the height is set just on the verge of tripping over, some DRO’s in the set will show regular and the others bold even tho the heights are all the same. (Don’t know why, probably a characteristic of the graphics card?)
The fix is to use Screen4 to increase all the heights of that group by 1 or 2 pixels.
Al
Re: Z axis 0
« Reply #3 on: May 03, 2009, 08:42:07 AM »
Hood,
I attached the file.
Thank you for your help.

Jim

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Z axis 0
« Reply #4 on: May 03, 2009, 08:49:58 AM »
OK your xml looks fine, can you post the code you are having problems with please.
Hood
Re: Z axis 0
« Reply #5 on: May 03, 2009, 09:20:46 AM »
I was carving many files, I think this is one of them. It happens on everything unless I regen 3-4 times.

Thank you.

Jim

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Z axis 0
« Reply #6 on: May 03, 2009, 09:27:35 AM »
Seems to be working fine here in simulation, the Z DRO shows the correct cutting depth.
 What I did was Home then jogged to a point away from home on all axis then pressed zero on all. I then pressed start, the Z went up to 0.75 then X and Y moved to the start, Z went down and all seemed fine.
 If that is not what you are doing can you please explain as best you can and I will try and replicate.

BTW you have jog control switched off so you will need to enable that before you can jog.

Hood
Re: Z axis 0
« Reply #7 on: May 03, 2009, 10:00:07 AM »
I use Shuttlepro as a pendant and it jogs with no problem.
When I start up the machine, I jog away from the home switches then home the machine to get all green lights. I load the g-code file then jog to my material. I usually have my X & Y zero at the center of the material. Then I jog the Z until it touches the material. At that point I set all axis to 0. When I regen the Z axis breifly shows 0.375 before showing zero. If I cut at that point the Z raises higher than normal, (sorry I didn't check the height but I think it's about .375) then comes down but never reaches the material before it starts running the file. To avoid this I regen 3 or 4 times and it works fine even though the 0.375 flashes every time I regen. Do you think I shold un-install Mach3 and install a fresh copy?

Jim

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Z axis 0
« Reply #8 on: May 03, 2009, 10:18:26 AM »
You can just install over the top of Mach, all important files should be overwritten.
 It seems to work fine here, I have simulated exactly what you have done and the DRO correspond to the G Code.
 One thing I noticed is you do not have Persistant Offsets checked, same with Persistant DROs and also Optional Offset Save. These should not make any difference  but you might find them useful.
 Anyway as I said it seems to check out fine here with your xml so looks like it may be something wrong in your installation.
One thing to check is the tooltable to make sure you have no offsets but even if that was the case then a simple regen of the toolpath would not sort things out so it has to be more than that.

Hood

Offline RICH

*
  • *
  •  7,419 7,419
    • View Profile
Re: Z axis 0
« Reply #9 on: May 03, 2009, 11:31:46 AM »
Jim,
Just a thought. Disable your Shuttle Pro and do the same routine you posted using the keyboard for jogging and see if there is any difference.
RICH