Hello Guest it is January 28, 2020, 09:24:47 AM

Author Topic: Feed hold corrupts coordinates  (Read 2804 times)

0 Members and 1 Guest are viewing this topic.

Feed hold corrupts coordinates
« on: April 26, 2009, 09:03:43 PM »
It seems like if I hit the Feed Hold button on Mach3, the machine is stopping before finishing its current move.  However, the coordinates are wrong.  I think what happened is the coordinates point to the end of the move it never finished. 

Anybody else see this, and is there a way to work around it?

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Feed hold corrupts coordinates
« Reply #1 on: April 27, 2009, 01:52:51 PM »
I have never seen that problem myself and its the first I have heard of it. What version of Mach are you using also what version of plugin. If you include your xml and code that it happens with I will try and see if I can replicate it.
Hood

Offline Jeff_Birt

*
  •  1,107 1,107
    • View Profile
    • Soigeneris
Re: Feed hold corrupts coordinates
« Reply #2 on: April 27, 2009, 04:02:36 PM »
If you are using Feed hold and tool offsets you will have problems right now. Brian has explained this has something to do with how/when the tool offsets are applied. I think 4.0 will have completely new code for offsets.
Happy machining , Jeff Birt
 
Re: Feed hold corrupts coordinates
« Reply #3 on: April 27, 2009, 05:28:59 PM »
I'll take a look again.  I kinda had the idea this was going to be a known problem for some reason, but I'll go through it with some more formal tests to see if it's actually doing what I thought.