Hello Guest it is December 04, 2021, 08:57:08 AM

Author Topic: Parallel port for PCI bus that works with Mach3 - just passing along info  (Read 67514 times)

0 Members and 1 Guest are viewing this topic.

Offline simpson36

  •  1,369 1,369
    • View Profile
Re: Parallel port for PCI bus that works with Mach3 - just passing along info
« Reply #20 on: February 09, 2011, 03:50:31 AM »
If you are getting any communication pins that work, it is likely all of them are working. The card would not be selective about which pins are functional.

The best port debugger is a BOB that has led indicator lights on each pin. No guesswork. Any voltmeter will suffice also (to see if the pins are changing state), but at a huge cost in time and convenience.

So it is easy enough to check out the LPT lines and see if Mach is talking to anything, but it does sound like you have a different problem than the parallel port.
Re: Parallel port for PCI bus that works with Mach3 - just passing along info
« Reply #21 on: February 09, 2011, 02:26:16 PM »
I too have struggled with getting a second printer port to work correctly.  I have an older SIIG with a NetMos 9835 chip and a newer card with the MosChip 9865.

I've updated the drivers and tried all sorts of stuff to get them working, but they still don't work right.

The one thing I have found that works for either card is as follows:

1.   Open the Ports and Pins Screen & set everything up in Mach (make sure both ports are enabled and the second port has the 2-9 inputs check-box selected.
2.   Close the Ports and Pins Screen.
3.   Re-Open the Ports and Pins Screen, deselect the 2-9 inputs check-box, click apply, reselect the 2-9 inputs, and click apply.
4.   Close the Ports and Pins Screen and everything works.

Each time I start Mach, I have to go through this process to get the second port to work.  When I first start Mach, the pins on the diagnostic screen are all lit up.  After going into Ports and Pins & toggling the 2-9 input check-box, the pins go out and everything works.

I know it sounds strange, but it works every time.  Could there be something strange going on with Mach?

Success at last
« Reply #22 on: March 18, 2011, 05:15:07 PM »
Well it all works now.  Thanks to Arturo at CNC4PC.com  and his C26 board.  Before this board,  I was having partial success, but the charge pump was not working.  As long as I kept the charge pump on the G540 to off all  worked.  I could jog the steppers through Mach 3.  If I disconnected the estop jumper I would get a fault (which it should). 

But I really wanted the charge pump to work the way it should.  The C26 board fits in between the PC and the g540.  It gets its power from a usb plug (included).  So for less than $20,  all works as it should. 

I had looked at a lot of forum posts and many have had the problem with not getting the charge pump to work with Mach 3, the Gecko g540 and a PCI parallel port card.    One post had suggested the C26 board (and also Arturo suggested it) and said it worked for them. 

So if your having this problem, I highly recommend the C26.

I really do not think it is possible to get it all to work using a pci parallel port card, a G540 and Mach 3 without using the C26 board.


I am also running a Windows 7 PC that came with no Parallel Port. I installed a PCI parallel port card and like many others, got no response from the Gecko G540. My experience matched most of the other threads regarding this issue on the forum; two ports listed in Device Manager, one labeled parallel and one labeled printer. Resource addresses did not actuate the router when entered in Mach Config - Ports and Pins, and the Diagnostics screen did not indicate any active pins.

None of the suggestions in the posts were successful for me (enable one, disable the other, vice versa, check and change addresses, change BIOS - Peripherals to EPP, then ECP, then EPP and ECP, many re-boots, setting addresses in Config Pins and Ports in Mach, uninstall and reinstall Mach, etc.)

After reviewing the motherboard documentation, I noted that there was an un-used parallel port connector (labeled JLPT1) on the mainboard. After entering BIOS, and DISABLING the Peripherals - Parallel Port entirely, then re-booting, Windows 7 recognized ONLY the PCI parallel port, and assigned an address range of E800 - E807. After I entered that address (E800) in Mach - Config - Ports and Pins in Port 1, the router immediately responded to my Shuttle Express. I successfully ran a test sample GC provided by the CNC router manufacturer.

It was a two day fight, but I believe I wrestled it to the ground.

Perhaps this might be a solution for someone else to try before buying more cards or equipment.  :)

As a computer and software literate user, I wonder why Geckodrive has stuck to old parallel port technology? Visit any computer brick and mortar or online store and you will be hard pressed to find a desktop with an installed parallel port. Seems like migrating to USB technology would be a logical next step. An additional benefit would be the ability to move the PC farther from the work surface hazards with inexpensive USB cables rather than the more expensive Parallel cables.

I am a CNC newbie just trying to help.

Offline BR549

  •  6,952 6,952
    • View Profile
The G540 cannot run on USB signals.To do that it would have to have an onboard MOTION controller like the Smoothstepper. NOW you could add the Smoothstepper to YOUR G540 and have usb connection to the computer. BUT that is sometimes frought with problems as well. The USB is NOT the best solution to CNC control.

Just a thought, (;-) TP
Re: Parallel port for PCI bus that works with Mach3 - just passing along info
« Reply #25 on: January 17, 2012, 11:43:20 AM »
Bumping this thread while helping a bddy through some lpt issues.
Re: Parallel port for PCI bus that works with Mach3 - just passing along info
« Reply #26 on: January 17, 2012, 02:27:02 PM »
Is anyone using a working PCIe card with mach?

Offline simpson36

  •  1,369 1,369
    • View Profile
Re: Parallel port for PCI bus that works with Mach3 - just passing along info
« Reply #27 on: January 18, 2012, 02:53:32 AM »
Is anyone using a working PCIe card with mach?
Hopefully someone will post a specific known working card, but I can give you some general guidelines. First, I would suggest using the card mentioned in this thread if it is still available and you have a compatible slot. That would be the safe choice.

If you must use PCIe, and you must choose an untested card, I would advise choosing a card with only parallel ports and not a 'multi function' card with other I/O on it. The fancier the card is the more 'tricks' and redirections the vendor uses and the less likely Mach will be able to talk to the card directly as is required. Since MOSCHIP is known to work, so you can seek out a card that uses their chip . . if possible use the same chip on the card referenced in this thread.

Lastly, get a dual parallel port card as you may find more success using both ports on the card and disabling any existing built in port. In my case, that proved to be the most stable and by far the fastest way to run.

edit: also you may have better luck using  a basic driver from the chipmaker's site and not the 'enhanced' driver that usually comes with the card.
« Last Edit: January 18, 2012, 02:56:40 AM by simpson36 »
is your computer with Windows 7 32 bit or 64. I'm trying not to have to buy an external controller for lots of money if I can use a PCI parallel port card on my 64 bit computer. thanks
Safe machining everyone

Offline Hood

  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
The parallel port driver will only work on a 32bit OS so it would not matter whether you could get a PCI card to work with W7 64 or not I am afraid.