Hello Guest it is November 18, 2019, 09:33:57 AM

Author Topic: not stopping in correct position  (Read 4564 times)

0 Members and 1 Guest are viewing this topic.

not stopping in correct position
« on: April 10, 2009, 09:41:10 PM »
Hi guys. I'm running into a ongoing problem with R2.0.060.

In MDI mode, and also at the end of programs, Mach stops the machine at the wrong position. I don't know if it's happening within programs, it doesn't seem like it, but my stuff is small enough that it might not be noticed.

For example, the last move in a program might be G00 Z1. The machine will move to Z.978 (or whatever number) and stop, according to the display, and the position is pretty accurate on the machine itself. It doesn't happen with every program, but if it does happen with a program, it's very consistent. It happens everytime, and it always stops at .978.

In MDI mode, I'll be at x5.0 or something, and enter G00 X0, and Mach will stop at X.492 (or something). Enter the command again, and it doesn't move. Jog the machine in X, enter the command G00 X0 again, and it moves to X0 like it should.

It doesn't happen all the time, but certainly enough to be frustrating.

Any ideas?

Thanks!

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: not stopping in correct position
« Reply #1 on: April 10, 2009, 10:23:37 PM »
What is your resolution?
Hood
Re: not stopping in correct position
« Reply #2 on: April 11, 2009, 04:23:45 AM »
Like Hood said, it is related to resolution for sure. Imagine that your hardware can only move in steps of 0.5mm.

If you are in Z=5 and ask the machine to go to Z=10.2, then the machine will go to Z=10, and displays Z=10, because it simply cannot reach Z=10.2, if you asked it to go to Z=10.3 then it would go to Z=10.5 (closer value)

Filipe
Re: not stopping in correct position
« Reply #3 on: April 11, 2009, 03:30:27 PM »
Hm, Ok I'm confused. (not hard to accomplish).

In inch mode, the resolution on each of the axis is .0001" on the main screen. I go to motor tuning, and each axis as 22,588 steps per unit, so there should be enough motor resolution to get within .0001-.0002"

I went into each of of the config drop down menus, and couldn't find anything labeled resolution. I also went to settings (alt 6) and didn't find anything.

Where do I find resolution and what should it be set at?

Thanks!

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: not stopping in correct position
« Reply #4 on: April 11, 2009, 03:43:07 PM »
the resolution is your steps per unit, well sort of as microstepping isnt totally exact so you could be slightly off.
 With a step per unit of 22,588 that means you have a resolution of  1/22.588 = 0.00004........... as said with microsepping it will not be exactly that but as far as Mach is concerned it will be, so that is not your problem.
 If you attach your xml I can have a look and see if I can find any ssues with it.
Hood
Re: not stopping in correct position
« Reply #5 on: April 11, 2009, 06:23:44 PM »
Thanks for the replies.

My XML is attached.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: not stopping in correct position
« Reply #6 on: April 11, 2009, 06:32:58 PM »
Try setting the kernel speed to 35KHz, also if it is a sherline mill you may be better using Sherline 1/2 Pulse mode (both of these on Ports and Pins main page).
Let me know if these help, if not I can look further.
Hood
Re: not stopping in correct position
« Reply #7 on: April 12, 2009, 12:31:15 PM »
Seems to have worked so far. If I have further problems, I'll post.

Thanks for the help