Hello Guest it is November 21, 2019, 07:07:17 PM

Author Topic: noob looking for guidance  (Read 4576 times)

0 Members and 1 Guest are viewing this topic.

noob looking for guidance
« on: April 09, 2009, 02:45:28 AM »
Have had my taig DSLS running Mach 3 for a couple weeks now and it usually runs perfectly fine through anything gcode I throw at it.  But sometimes it stops with a 'limit switch' error though it is far from any limits, this might happen 30 seconds into a run or 2 hours into a run.  I believe this is the clasic missed steps error being caught because the encoder/move got out of sync but feel free to correct me if I am misunderstanding.  With maybe 40-45 hours on the clock I have had just 5 of these stops.

Being new I looked around but am still a little confused on the correct interpretation of the driver test and motor tuning options.  I am pretty zelous about keeping the ways cleaned and lightly oiled and it does not seem to be any binding or undue looseness (.0015 x, .0010y backlash).  The stall can happen either in x or y so I lean away from a mechanical issue.  as a test on the last stop I just restarted the spindle and hit cycle start and it picked up and ran through the rest of the gcode (albiet out of alignment) I also reran the gcode on a new block of material and it ran through to the end without a problem.  I have run the driver test and it reports excellent at all speeds 25k up to 100k.  I went through motor tuning and had it set at 80 ipm 5 accel which worked fine but backed it down to 60 ipm 2 accel after the second stall and it still stalls.  This is on a Compaq desktop, athlon 3500+, Xp home, 1.5GB RAM, PCI video.   I am using the built in parallel port, and the BIOS on the compaqs are not really full featured but if there are specific setting I should look for I will dig through there and see what options are available.

Any ideas where to focus my attention to eliminate these random stops would be appreciated, it's getting annoying to hit a stall after 2 hours in a 3 hour run, I suppose once I get better at repeatible zeroing the axis it might not be as bad, right now I usually just chuck the stalled jobs in the recycle bin because getting back withing .005 seems to be the best I can do and doing PCB etching that does not cut it.

Thanks for any insight you more experienced folks can pass down.
Mark 

Offline Tweakie.CNC

*
  • *
  •  8,008 8,008
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: noob looking for guidance
« Reply #1 on: April 09, 2009, 03:20:29 AM »
I had a similar problem in the past which turned out to be noise spikes on the LPT parallel port. Not only was it causing random EStop's it was also causing false steps. I fitted a PCI parallel port card and this completely cured the problem.
Are you using screened cable (grounded at one end only) for your limit switches and EStop ?

Tweakie.

btw. You are not a noob you are on equal ground to the rest of us - we are all still learning.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: noob looking for guidance
« Reply #2 on: April 09, 2009, 03:27:33 AM »
Sounds more like noise than motors stalling. If it was motors stalling then it would not throw a limit switch error.
Go to General Config page and set the debounce Interval to 2000, then if that cures the random limit errors drop it down until they start happening again then increase slightly.
Hood
Re: noob looking for guidance
« Reply #3 on: April 09, 2009, 03:46:11 AM »
Thanks for those replies, I didn't think about it but noise makes a lot of sense, I will bump up the debounce and see how that works out tomorrow.   I am in a cramped condo so right now my cable routing is not the best with power and data runs intermingled I will also sort out that cabling to eliminate that as a noise problem spot as well.

Tweakie,
  I was looking for a PCI parallel port yesterday but the 2 stores I went to didn't have any, planning on going to Fry's tomorrow at lunch time they will almost certainly have some in stock.  the drive and encoder cables are standard Taig cables  that I believe are shielded but will check on that.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: noob looking for guidance
« Reply #4 on: April 09, 2009, 04:12:42 AM »
Make sure the shielding is connected to Earth at one end only, preferably the control end and also if possible all connected together at one point on the cabinet.
Hood
Re: noob looking for guidance
« Reply #5 on: April 10, 2009, 09:38:30 AM »
I believe Hood hit the nail on the head with the noise idea, setting debounce to 2000 and I ran 8+ hours without a stop error yesterday.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: noob looking for guidance
« Reply #6 on: April 10, 2009, 09:46:22 AM »
Great :)
Might be worth lowering it a bit at a time until you get the problem again then jumping back up a step. With the problem being intermittant it may be a bit of a pain to do that though.
Hood
Re: noob looking for guidance
« Reply #7 on: April 10, 2009, 11:37:37 PM »
indeed debugging intermittent issues can be a real pain in the butt. Unless I run into a problem with the debounce up at 2000 is there a particular reason to lower it?

If I understand the option correctly: 2000*40us = 80ms., so if a signal is 79ms long it ignores it but if it's 81ms then it triggers (+- 1ms or something close depending on kernal speed).  if the axis is moving at 60 in/min = .08"  (60/60,000 = .001 inch/ms * 80ms debounce) so I might get up to .1" or so over travel while it is waiting for the debounce timer I guess that could be an issue if I overran limits at my full slew rate. 

So much math so few brain cells working today  ;)

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: noob looking for guidance
« Reply #8 on: April 11, 2009, 04:48:08 AM »
That is the only reason :) With your machine only doing 60IPM it probably wont be an issue.

Hood