Hello Guest it is July 21, 2019, 09:39:21 AM

Author Topic: I can't get my xbox control to work  (Read 3682 times)

0 Members and 1 Guest are viewing this topic.

I can't get my xbox control to work
« on: March 25, 2009, 10:52:14 PM »
I am new to this, and am in the process of trying to make my cnc router move.  I added xbox 360 plugin, Mach 3 recognizes the xbox controller, I configured the buttons, and no movement. No messages or anything. The Zenbot driver is turned on, everything's plugged in. I havent configured the steps/inch yet, mabye thats it? I couldn't figure out how to configure the steps/inch settings. I have the numbers, just don't what to do with them. Thank you for any help you can give, I really appreciate it.
« Last Edit: March 25, 2009, 10:53:52 PM by avirostick »

Offline RICH

*
  • *
  •  7,342 7,342
    • View Profile
Re: I can't get my xbox control to work
« Reply #1 on: March 26, 2009, 12:30:26 AM »
avirostick,
1. In config>config plugins you need to have the xbox enabled and then click on config and configure it.
    You can't have joystick or shuttle pro enabled also.
     If C:\Mach3 is your installed directory for Mach, then go to C:\MACH3\PLUGINS and move
     Joystiick.dll   &    ShuttlePro.dll  to a safe place or as i have done, created a sub-directory under plugins
     and placed the files there. Now they will not appear in the config plugins pull down.
     You should have a file called    XBoxController.dll   in the plugins directory.
2. Have you or is Mach configured?
    check config>ports & pins>input signals  and check and see if the EStop is enabled. You can assign an
     unused port pin # and click emulated.
3. Make sure all the other configs are also configured properly.

Do you have steppers or servos?

Have you read the manuals? The new "Mach3 CNC Controller Software Installation and Configuration"
which can be downloaded convers a lot of topics on what to do.

Forgot to mention, welcome to the CNC journey.  ;)
RICH

« Last Edit: March 26, 2009, 12:32:50 AM by RICH »
Re: I can't get my xbox control to work
« Reply #2 on: March 26, 2009, 07:05:07 AM »
Thank you Rich. I appreciate your help.  The joystick and shuttle pro were enabled, so I'll disable them and try. I haven't done anything with enabling the Estop, or configured the ports and pins. This might be the reason it's not working. They are stepper motors, and the kind gentleman I bought the router from included the configuring formulas for the steps/inch. I just was confused when I looked in the Mach config pulldown, I couldn't find out where to apply these figures.
 I may have been a little excited and hurried  through too fast!
« Last Edit: March 26, 2009, 07:09:46 AM by avirostick »
Re: I can't get my xbox control to work
« Reply #3 on: March 26, 2009, 08:20:46 AM »
Ok, I finally got some movement. Obviously now it's a matter of configuring the ports and pins because the xbox controller will allow it to jog some axis', but not do everything it's told. On mach screen, it says y is moving but it's not, X only jogs in one direction,etc. So, is configuring the ports and pins just a matter of clicking "enable" on certain things? This is very confusing. I emailed the guy I purchased it from and asked about xml. Am I on the right track?

Offline RICH

*
  • *
  •  7,342 7,342
    • View Profile
Re: I can't get my xbox control to work
« Reply #4 on: March 26, 2009, 08:47:22 AM »
Yep, get the configuration correct first and be able to jog with the keyboard. With that in place,
then you can configure the xbox since everything is working correctly. Please take a look at the manual
as this could turn out to be a very long communication.
RICH
Re: I can't get my xbox control to work
« Reply #5 on: March 26, 2009, 03:22:25 PM »
I got it all straightened out. I got the xmf file straight from the maker, pasted it in the mach folder, and after configuring a few buttons on the xbox controller, it works like magic. Sure beats trying to figure it out! Thanks for your help all, a little progress a day is all one can ask for.

Offline RICH

*
  • *
  •  7,342 7,342
    • View Profile
Re: I can't get my xbox control to work
« Reply #6 on: March 26, 2009, 06:57:16 PM »
Over time you'll get to figure it all out. ;)
Glad all is working.  :)
RICH