Hello Guest it is October 22, 2019, 08:26:16 AM

Author Topic: Metric setting leaves little space for values  (Read 2586 times)

0 Members and 1 Guest are viewing this topic.

Offline peu

*
  •  23 23
    • View Profile
Metric setting leaves little space for values
« on: March 11, 2009, 06:12:31 PM »
I have installed version 2.79 wizards from latest mach3 stable release. My machine is configured for millimeters.

for us metric people, 4 zeroes after the decimal point is too much, leaves little space for the integer part of the numbers and the +/- sign, it would be nice to have more space for large metric numbers :)

Thanks!


Re: Metric setting leaves little space for values
« Reply #1 on: March 11, 2009, 07:40:52 PM »
Thats a hard one to fix- there are probably 100 or more DROS, and changing them all would mess up every screen.

The program saves the same size number in all cases, so you can enter more digits than show in the DRO. I know that would be an ugly way to do it, but it should work OK. The code generated will have the full numer.

Sorry I cannot be more helpful on this one.

Offline Greolt

*
  •  956 956
    • View Profile
Re: Metric setting leaves little space for values
« Reply #2 on: March 11, 2009, 09:08:15 PM »
Peu

That is fairly easy to make the changes yourself to the DROs that are a problem with metric.

I doubt you would want to change them all.  Only the ones that are a relevant.

This can be done in Screen4.  The relevant page numbers are about 20 to 35

I have changed a few that used to annoy me.  Just made them 2 decimal places.

Greg