Hello Guest it is October 16, 2019, 11:38:35 PM

Author Topic: Need Help: Z-Axis Reversed  (Read 2400 times)

0 Members and 1 Guest are viewing this topic.

Need Help: Z-Axis Reversed
« on: February 19, 2009, 01:47:30 PM »
Hello,

I am using Mach3 on a Syil X4 Mill. Everything has worked great for months, but now my z-axis directions are reversed.  When I jog or enter code to move in the positive z-direction, the mill goes in the negative z direction.  The opposite is true for moving in the negative z direction.  My x and y axis work normally.  Can anyone help me fix this?

Jon
Re: Need Help: Z-Axis Reversed
« Reply #1 on: February 19, 2009, 02:31:40 PM »
Did you change any wiring?  This can happen if the motor leads get re-arranged.  Easiest fix is to go into Config->Ports&Pins->Outputs, and change the polarity for the Z axis DIR signal.

Regards,
Ray L.
Regards,
Ray L.
Re: Need Help: Z-Axis Reversed
« Reply #2 on: February 19, 2009, 02:36:04 PM »
three ways to do it...

1. Swap your stepper motor cables, for the same winding. Just swap A and A'

2. In mach go to motor ports and pins and in your Z axis change your dir low active settings to the opposite it is right now.

3. and probably the easiest, go to choming/limits under the config menu, and check the reversed checkmark for your z axis.

hope that helps
regards
Fernando
Re: Need Help: Z-Axis Reversed
« Reply #3 on: February 19, 2009, 02:51:28 PM »
THANK YOU! I went to Config>>> Homing/limits, and toggled the z in the "Reversed" column.  Easy fix.  Thanks!