Hello Guest it is April 17, 2021, 11:33:31 AM

Author Topic: CNC Problem under Mach  (Read 3199 times)

0 Members and 1 Guest are viewing this topic.

CNC Problem under Mach
« on: February 14, 2009, 01:01:33 PM »
Hello,

I own a Camwood WR510 CNC router running under Mach and was looking for some advice regarding a problem I'm having with it.

It's been about a year now that I've had the machine and I'm just getting some steam with it while getting other cnc-related matters in place (no hurry since I also have a business to run) and, having cut only a few small, light duty jobs that, in and of themselves, didn't manifest the problem; it's only now that I'm seeing it with more intense cuts.

When I came to carve my vacuum plenum recently did I see it. I immediately put a dial indicator on the spindle and disovered it was .012 out E-W and .008 N-S. However, I don't think that is solely to blame for the cutting anomally I'm experiencing.

What it boils down to (and I have been communicating with the factory under my warranty about this): After cutting the tool paths and the machine is returned to X,Y,Z = 0; when I go to cut same pattern, slightly deeper, the cut is noticeably off-path. Personally, I think its either the motors, gearing or rails as well as the spindle orientation.

At the time my machine was shipped, it shipped to the factory from overseas for an inventory stop and then to me. It wasn't standard practice for the company to uncrate, assemble and test before shipping as it is this year. The plenum carve was probably the most rigorous I've used the machine.

That's about as much as I can tell right now. Have done some test cuts and the result is always the same. I have sent a test cuts into the the company from their code, but not sure it will reveal the
"off path" data I'm observing.

Thanks to anyone who can advise.

Fran in NJ

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: CNC Problem under Mach
« Reply #1 on: February 14, 2009, 05:03:32 PM »
Can you confirm that the machine is actually returning to the correct X0 Y0 ZO position? Your problem could be backlash.
Hood
Re: CNC Problem under Mach
« Reply #2 on: February 14, 2009, 06:51:42 PM »
Good point, Hood, and thanks. I assumed so since I cut the vacuum plenum in stages; i.e., gaskets, zones grids, etc., and (ignoring Z for the moment) the raised areas between gasket and zones in both X,Y remained visually and (measureably) accurate between cuts using same X,Y=0

Is there a definitive method for checking X,Y,Z accuracy? I can imagine a few tests.

These machines are an open-loop system. There are no limit switches in the extreme X,Y and when I first received this machine, when moving the gantry around, it did "bottom out" and bump a few times. In fact, the Z sensor was bent and it did the thumpity-thump until it was corrected.

I recently learned from two other owners of Camwood machines that banging of the machine at the end of travel can cause stepper motor problems, not to mention bent gears. I've recommended to the mfgr. that they put limit switches in these extreme locations and I understand that they are now doing that as well as assembling and testing their machines at the factory prior to shipping. I've asked for a tech to come out and give it the go-over as they do at the factory since I'm in urgent need to use it currently.

This machine, in traveling how many thousands of miles from China?, I can't imagine that something doesn't go askew with X, Y, and Z. I'm waiting for a response, but they've been
good to work closely with me so far.

Thanks again for your insight.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: CNC Problem under Mach
« Reply #3 on: February 14, 2009, 07:18:18 PM »
I suppose the easiest way would be to chuck a drill, move to some arbitary position and zero the DROs then move the Z down to drill a hole, move it up then command a few X and Y moves via the MDI line then lastly command a X0 Y0 move and then move down on the Z and see if your drill is in the same position, it will be surprising how accurate that will be as you will soon see if you drill new material.
 To test for Backlash you could mount a clock (DTI)on the table and move it in one axis so its against the spindle, Zero Machs DRO and put jogging into step mode and setp away in the opposit direction until you see the needle move, the DRO in Mach will be reading the amount of backlash you have. You will need to repeat for each axis.

Hood
Re: CNC Problem under Mach
« Reply #4 on: February 14, 2009, 08:00:59 PM »
Thanks, again, Hood. I'll have to read and study the second part some to fully understand what you're suggesting.