Hello Guest it is December 12, 2019, 01:58:46 PM

Author Topic: ESTOP not assigned to SmoothStepper Input?  (Read 9629 times)

0 Members and 1 Guest are viewing this topic.

ESTOP not assigned to SmoothStepper Input?
« on: February 13, 2009, 11:04:18 AM »
I posted the following on the fourm at Warp9 web page, but no reply. I am guessing they don't check their webpage that much. Maybe someone here can explain to me why this message appears and what I have not done.
thanks



ESTOP not assigned to SmoothStepper Input?
I have just gotten smoothstepper installed, I had no problem following the instructions, which is a plus for me. When I load up Mach3 I get the above message, I can hit Reset in Mach3, get the above message a second time, close that and everything then works fine. I assume I have not done something right.

One more thing, which might relate to the above. When using Mach3 before and I hit the space bar on the keyboard the sherline mill would stop, I notice now that when I do this it keeps going for a short time before stopping. Is it possible to add an Estop button onto the Smoothstepper?

Thanks for any help.
Jim
         

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: ESTOP not assigned to SmoothStepper Input?
« Reply #1 on: February 13, 2009, 04:41:07 PM »
If you do not actually have an E-Stop configured just pretend that you do by setting it up in Ports and Pins and asigning a Port and Pin number then change the active state to suit.

As for the feedhold being slow, that is just a fact of life on the SmoothStepper as the buffer has to empty. The slower you have the controller frequency the longer it will take, if your compter is happy with 4KHz frequency then it will stop almost as quick as the parallel port, try 2KHz first though and see what its like.
Hood
Re: ESTOP not assigned to SmoothStepper Input?
« Reply #2 on: February 14, 2009, 03:38:28 PM »
Thanks Hood, so simple a fix, no more warning on start up. I think because of the way I have reset the equipment that I will add an E stop button near the machine once I can find a proper switch to work it with.

again thanks

Re: ESTOP not assigned to SmoothStepper Input?
« Reply #3 on: April 07, 2013, 05:37:10 PM »
i love you hood! you have no idea how long i worked on this this afternoon!!_CAM