Hello Guest it is June 15, 2019, 07:18:43 PM

Author Topic: Limit switch issues  (Read 3670 times)

0 Members and 1 Guest are viewing this topic.

Offline DAlgie

*
  •  304 304
    • View Profile
    • Algie Composite Aircraft
Limit switch issues
« on: July 22, 2006, 12:32:53 AM »
My lathe has it's X axis home/ limit switch at the end of the axis' travel. The Z axis one is somewhere in the middle of it's travel. My problem is, when I go to set home with both, the Z axis will go there, then reverse off and stop, with no problems. The X axis however, when it goes there, then reverses, I get a limit switch triggered error, and I can't jog or go anywhere anymore. I have used a workaround in tabbing to the jog flyout screen, then switching off the limits override button, then jogging off, then switching the limits override back on again, but it shouldn't be like this. Any ideas?
Re: Limit switch issues
« Reply #1 on: July 22, 2006, 09:39:58 AM »
Are you using the same switch as a home switch and limit switch?
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com

Offline DAlgie

*
  •  304 304
    • View Profile
    • Algie Composite Aircraft
Re: Limit switch issues
« Reply #2 on: July 22, 2006, 11:18:23 AM »
Yes, the X axis does, and it's the one I have a problem with, the Z axis switch is in the middle of the travel, and never gives this problem.
Re: Limit switch issues
« Reply #3 on: July 22, 2006, 12:02:12 PM »
Do you have the limit switch and the home set to the same pin?  This should work and I will have Art look at that when he gets back...
Thank you
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com

Offline DAlgie

*
  •  304 304
    • View Profile
    • Algie Composite Aircraft
Re: Limit switch issues
« Reply #4 on: July 24, 2006, 12:23:01 AM »
Yes, limit and home are the same pin. One thing I noticed tonight, the setting that drives the axis off the switch has no effect, I had both set at .100", and then wondered if the X, beacuse a lot (but not all) settings are in radius, that it was actually only going .050", which I think it is. I changed it, all the way up to .500", and it never drove off any more than it did when it was set at .100". Tried closing the program down and opening it again to see if that made a difference, nope.

Offline DAlgie

*
  •  304 304
    • View Profile
    • Algie Composite Aircraft
Re: Limit switch issues
« Reply #5 on: July 29, 2006, 01:21:42 AM »
Brian, any info on the limit switch info? Thanks!