Hello Guest it is May 26, 2019, 09:57:01 AM

Author Topic: What The????  (Read 4020 times)

0 Members and 1 Guest are viewing this topic.

What The????
« on: February 02, 2009, 12:15:44 AM »
I have Mach3 installed on my home laptop, for testing purposes.  I disabled all the home/limit switch inputs in Config->Ports&Pins. When I click the "Ref All Home" button, a little dialog pops up, with a title bar that says "Answer This:", the dialog says "What Are You Doing?", there's a text entry box with the number "0" pre-filled-in, and an OK button.

What the hell is that for????  Isn't there a way to clear machine coordinates with no home switches?

Regards,
Ray L.
Regards,
Ray L.

Offline Hood

*
  •  25,827 25,827
  • Carnoustie, Scotland
    • View Profile
Re: What The????
« Reply #1 on: February 02, 2009, 03:01:32 AM »
Never seen that, what version do you have? What screen are you using?
 Normally with no home switches set the axis with zero to machine coords when ever you press the RefAll button, presuming of course you have Auto Zero checked in Homing and limits.
Hood
Re: What The????
« Reply #2 on: February 02, 2009, 11:28:19 AM »
Hood,

    I'm getting this with the stock 1024 screenset.

Regards,
Ray L.
Regards,
Ray L.
Re: What The????
« Reply #3 on: February 02, 2009, 11:35:32 AM »
The Ref All Home button on the Settings page works as it should.  The one on the Program Run page brings up the goofy dialog.

Regards,
Ray L.
Regards,
Ray L.

Offline Hood

*
  •  25,827 25,827
  • Carnoustie, Scotland
    • View Profile
Re: What The????
« Reply #4 on: February 02, 2009, 11:47:25 AM »
what is the script in the button? sounds like its been messed with.
Hood
Re: What The????
« Reply #5 on: February 02, 2009, 12:23:59 PM »
what is the script in the button? sounds like its been messed with.
Hood

Hood,

'DoButton( 24 )
'DoButton( 23 )
'DoButton( 22 )
'DoButton( 25 )
Question("What Are You Doing?") 

I didn't change it.  This is how it installed - v3.042.015.

Regards,
Ray L.
Regards,
Ray L.
Re: What The????
« Reply #6 on: February 02, 2009, 01:37:16 PM »
I just installed the latest lockdown, and it's now correct.  Don't know how that got in there....
Regards,
Ray L.

Offline Hood

*
  •  25,827 25,827
  • Carnoustie, Scotland
    • View Profile
Re: What The????
« Reply #7 on: February 02, 2009, 01:48:46 PM »
Think someones been messing with you LOL
 Will see if I have that version to see if its the same.
Hood

Offline Hood

*
  •  25,827 25,827
  • Carnoustie, Scotland
    • View Profile
Re: What The????
« Reply #8 on: February 02, 2009, 01:53:32 PM »
Just installed that version and standard screen is fine.
Hood