Hello Guest it is May 21, 2019, 01:16:41 PM

Author Topic: MDI does not honor machine parameters?  (Read 3058 times)

0 Members and 1 Guest are viewing this topic.

MDI does not honor machine parameters?
« on: January 15, 2009, 05:33:36 PM »
When you input a command through MDI that exceeds the soft limits, it just goes for it and depending on speed, can crash. Is there a way to make the MDI follow software limits?

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: MDI does not honor machine parameters?
« Reply #1 on: January 15, 2009, 05:36:13 PM »
I think that may again be a problem related to the DSPMC as its fine with the parallel port, I have just tested here.
Best bet is talk to Rufi and see if he can update the plugin.
Hood
Re: MDI does not honor machine parameters?
« Reply #2 on: January 15, 2009, 05:39:01 PM »
Are you absolutely sure that you have the Soft Limits set properly and are ENABLED ?
It works as it should here.
RC
Re: MDI does not honor machine parameters?
« Reply #3 on: January 15, 2009, 05:41:05 PM »
If im in the program window, i can job and it decels and stops on the limit (107") if i flip to the MDI window and say "x= 200" it will try....

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: MDI does not honor machine parameters?
« Reply #4 on: January 15, 2009, 05:44:21 PM »
It works fine with the parallel port so its not a Mach issue, it will be related to the way the softlimits have been done in the plugin for the DSPMC.
Hood