Author Topic: HELP!!! Wired my drivers can't get my motors to turn  (Read 4597 times)

0 Members and 1 Guest are viewing this topic.

Offline Sixgun_slim

  • Active Member
  • Posts: 11
    • View Profile
HELP!!! Wired my drivers can't get my motors to turn
« on: January 14, 2009, 08:53:56 PM »
OK

hardware:
automation direct power supplies, motor drivers, motors, motor cables
cnc4pc breakout board

Wired drives and motors and tested using the test dip switch and the motors turned in both directions - switched back to run
stepper driver set to 1/2 step

P4 IBM 2 gig computer.

hooked up via lpt port

ran thru video tutorials up to motor tuning and this is where I realized I had a problem - motors wouldn't turn with arrow keys checked my motor pin out and wiring. LPT port is on board existing lpt port set to default 384 eps mode no interupts

motor shaft locked up tight.

Is there a way to test??

I wire up the step- and direction - to the breakout board -  enable is not wired is this the problem?? if so where does this go??

Any and all help appreciated

Sixgun

Offline Sam

  • Global Moderator
  • *
  • Posts: 987
    • View Profile
    • hillbillyhilton.com
Re: HELP!!! Wired my drivers can't get my motors to turn
« Reply #1 on: January 15, 2009, 01:53:40 AM »
Taken from manual...

Enable Pin:
The card must be provided with a 5VDC signal to enable operation. This feature has been
added to enable you to control externally the status of the card. You can add en external
switch or a Safety Charge Pump to provide the enabling signal. When the enable signal is
not enabled, the communication with the computer is interrupted. If you need the
communication to be enabled at all times you can provide the 5 volts directly from the source
that is powering the card.
"CONFIDENCE: it's the feeling you experience before you fully understand the situation."

Offline Sixgun_slim

  • Active Member
  • Posts: 11
    • View Profile
Re: HELP!!! Wired my drivers can't get my motors to turn
« Reply #2 on: January 15, 2009, 06:31:32 PM »
Sam

OK I kinda thought maybe this was the problem but I wasn't sure,  so if I understand you correctly if I run enable - to ground ?  and run 5v to enable + on my stepper drives, this will allow mach 3 to communicate with my motors. I only want to be sure cause I went through the Mach manual and my stepper drive info sheet after reading your post and I couldn't really see where it spelled it out. But some of the terms in the manuals I don't really understand.

And THANK YOU in advance for your help and patience.

Thanks,

Sixgun

Offline Sam

  • Global Moderator
  • *
  • Posts: 987
    • View Profile
    • hillbillyhilton.com
Re: HELP!!! Wired my drivers can't get my motors to turn
« Reply #3 on: January 15, 2009, 06:53:31 PM »
Dunno exactly what card you have, but I'm sure you could download the manual for the breakout board from CNC4PC. I wired mine with a small loop wire from the +5v to EN pin. I purchased mine quiet some time back, so be sure and look at the manual just to be sure on the voltages and such for the enable pin.
"CONFIDENCE: it's the feeling you experience before you fully understand the situation."

Offline Sixgun_slim

  • Active Member
  • Posts: 11
    • View Profile
Re: HELP!!! Wired my drivers can't get my motors to turn
« Reply #4 on: January 15, 2009, 07:33:07 PM »
Sam,

Rechecked my breakout board and I don't have an enable on it - do I need one??. I was referencing the enable on my stepper drive BUT i just reread the info on the stepper drive and it says that the enable is normally closed meaning it will enable control to the motors UNLESS wired so I don't think that's it. I'm going to check my cable pin by pin for continuity next. is there some way to read voltage at the cable when trying to control the motors from MACH3??

Offline Sixgun_slim

  • Active Member
  • Posts: 11
    • View Profile
Re: HELP!!! Wired my drivers can't get my motors to turn
« Reply #5 on: January 15, 2009, 07:41:27 PM »
Alright I might be getting somewhere I got a cable from a friend male to male extension and I only get resistance thru pin 25???? all other pins read open. This isn't correct right??? If not correcct where can I buy the correct cable. 

Sixgun

Offline Sixgun_slim

  • Active Member
  • Posts: 11
    • View Profile
Re: HELP!!! Wired my drivers can't get my motors to turn
« Reply #6 on: January 15, 2009, 09:00:32 PM »
Doing a little searching I found out the wire I have is a null cross db25 belkin wire, -  I just found a pass thru db25 m/m wire on ebay. Let's hope that's it.

Sixgun

Offline Sam

  • Global Moderator
  • *
  • Posts: 987
    • View Profile
    • hillbillyhilton.com
Re: HELP!!! Wired my drivers can't get my motors to turn
« Reply #7 on: January 15, 2009, 11:22:05 PM »
Quote
Rechecked my breakout board and I don't have an enable on it - do I need one??
If it don't have an enable on it, then no, you don't need one.
"CONFIDENCE: it's the feeling you experience before you fully understand the situation."