Hello Guest it is July 14, 2020, 06:06:00 PM

Author Topic: Support Question: Motors stall after powering down during long perpendicular run  (Read 7645 times)

0 Members and 1 Guest are viewing this topic.

Hey,

   I am new to Mach3, and am still trying to figure it out. I have run into a problem, however, and any adivce would be appreciated. The problem is that my motors are powered up, then for example, the x or y axis do a long run in a 3D cut. After running the length, it happens that it took so long that the perpendicular motor powered down. In powering back up, the motor stalls, and so it misses that slight jog to align the next long run. Is there any way to configure Mach3 to keep the motors powered up longer, so they do not stall as such?
   Thank you, all who reply.

Offline RICH

*
  • *
  •  7,411 7,411
    • View Profile
storenfwi,
You have my interest on this one. I use steppers and they "never power" down unless i manualy flip a switch
on my controller to disable one or all of them. I am not aware of any setting in MACH that would do that.
You may want to provide a little more info on the drives you are using and how long is a long time.

When you say power back up and stalls........... Ii am thinking that you are missing steps becuase of to high
an acceleration.  When you say long time.........if you have high current setting and they sit there a "long" time and get hot they can start to act funny.  Just quessing. Post some some more iinfo.
RICH
Thanks for the input. Perhaps I am wrong about them powering down. As far as the length of time, perhaps 20-30 seconds? I have tried turning down the acceleration, but am not sure how much. I am currently running at about 35 in/min, and an accel of 10. My driver is a HobbyCNC driver, and the steppers are 305 oz/in. For machining anything where each axis is activated within 30 seconds of previously being activated, it works great. On the larger stuff though, where one axis is dormant longer than about 20-30 seconds, it stalls out and misses its line of g-code. Thanks again.

Offline RICH

*
  • *
  •  7,411 7,411
    • View Profile
Quick look at the Hobby CNC site says:
 
"Idle Current Reduction to 50% when idle for 10 seconds. Can change this time delay. "

There should be no need for this when running a program. Take a look at your documentation
for your driver as i am not familar with them.  Let us know how you make out.

RICH
I am having what I think is the exact same problem.  I've been working on solving it for almost 80 hours now and I'm about to throw the whole CNC out the window.

I am running Vexta PK296-01AA motors on the HobbyCNC driver with Mach3.  Whenever I do a long traverse in X and/or Y, Z Goes into Synchronous mode after 10 seconds.  I have the idle current reduction (jumper 4) turned off.  When the motor comes out of Synchronous mode, it always has trouble with the first hand full of steps.  I can see the motor trying to move, but not moving correctly for less than 0.25 seconds (I recorded this  with HDvideo) after that it goes into normal mode and runs fine.  I generally lose about 0.02 inches after every long pause... this is enough to ruin the thin PCB that I'm trying to mill.

I have tested this thing to death and am sure that it is not mechanical.  There is very little backlash, and very little resistance on the screw... I guarantee it is not losing steps because of mechanical friction or binding.

I also have a CNC control program that I wrote from scratch in C that does not have this problem, but is far from running complete Gcode... so I need something like Mach.

I am desperate for help!!!  Any Ideas anybody
I am having the same problem.  I ran into a thread in CNCZone that addresses this issue with the HobbyCNC boards: http://www.cnczone.com/forums/showthread.php?t=49043.  I haven't done this yet but I will this weekend.  Makes perfectly good sense!

Offline RICH

*
  • *
  •  7,411 7,411
    • View Profile
Has anyone contacted HobbyCNC? What do they say?
RICH
I've posted an inquiry on the HobbyCNC forum.  There's a thread there about this, too.  Back in November '07, they were talking about it.  Seems a couple of the guys there have worked on it but the thread died.  We'll see..............
Here's the thread: http://groups.yahoo.com/group/HobbyCNC/message/14911
No answer on the HobbyCNC board about using Mach's current control on the Pro boards.  I have incorporated a relatively simple work-around until I get around to modifying the boards to use Mach 3 to control the current.  I replaced the J4 jumpers with a switch.  I disable current reduction (switch open) during cuts and turn it back on when the project cut is done.  The best of both worlds!  No lost steps after tool changes or other long idle periods during a program run and I don't have to turn everything off to keep the motors cool during non-use periods.  I did post the question on the HobbyCNC forum and Dave reluctantly agreed that switching the current reduction on and off while the board was powered up wouldn't do any damage.  I ran it all day yesterday, switching current reduciotn on and off about 30 times and didn't have any problems.  I did keep the axes separate - using a 3-pole, single throw switch - since I didn't research the jumper circuit to see if it would work if I connected the 3 axis channels together.

Offline RICH

*
  • *
  •  7,411 7,411
    • View Profile
Unfortunately, your problem is HobbyCNC / their system, and they need to address the issue. Mach or any controlling  program delivers the pulse and the controller ( power supply, drives, and associated electronics ) should respond.

 Maybe you should think about a different drive to better suite what you are doing?
 
Kind of like driving down the road, and the motor is automaticaly shuts off , you go to pass someone, and can't!

Ask Hobby CNC why they "designed" their driver like that and what "they" recommend as a fix and also "their"   definiton of intended use of their product.

Just my nickle for what it's worth,
RICH