Author Topic: need help Setting up external ref all home button  (Read 2674 times)

0 Members and 1 Guest are viewing this topic.

Offline kencor1

  • Active Member
  • Posts: 103
    • View Profile
    • Kencor Stairs & Woodworking
need help Setting up external ref all home button
« on: November 11, 2008, 02:15:58 PM »
I am trying to set up an external input button to Ref all axis home. I tried using the OEM code 105, but when I run it the z axis will home hits the switch but does not reverse it keeps trying to go up. Am I doing something wrong or is there a better way that I should be trying to do this.

Thanks,
Tom

Offline Hood

  • Mach4 Alpha
  • Posts: 25,775
  • Carnoustie, Scotland
    • View Profile
Re: need help Setting up external ref all home button
« Reply #1 on: November 13, 2008, 04:33:05 AM »
What I did (I think as it was a while ago) was set up an input for the switch then made a macropump with the RefAll VB in it. enable the macropump and restart and it should work when you press the button. If you use the standard RefAll functions then using Input 4 this would be what your macropump needs in it.

If IsActive (input4) Then
 DoOemButton (1024)
 DoOemButton (1022)
 DoOemButton (1023)
 End If 


Hood

Offline kencor1

  • Active Member
  • Posts: 103
    • View Profile
    • Kencor Stairs & Woodworking
Re: need help Setting up external ref all home button
« Reply #2 on: November 18, 2008, 04:43:32 PM »
Thanks Hood,  I just now got around to setting it up and it worked like a charm.

Thanks again
Tom