Hello Guest it is May 17, 2021, 09:19:02 AM

Author Topic: Using a gamepad, it seems great, then it will continue movement in one direction  (Read 4590 times)

0 Members and 1 Guest are viewing this topic.

Offline Tarak

*
  •  227 227
    • View Profile
I'm testing using a Logitech Wingman cordless gamepad & keygrabber, for the most part it seems pretty good, the potential is awesome.
But the main issues I'm having is keygrabber doesn't save my settings, even if I click SAVE AS then Default.grab
Once I restart the settings return to what they were...... I even tried deleting the .grab files and starting again, but it won't save my settings for X axis.

Anyhoo's randomly after I've moved the machine in X, Y or Z using the gamepad, it will continue moving even after I've released the joystick (DAMN Dangerous).
The only way to stop it is to move the same axis in the opposite direction.
Is this a common issue with keygrabber, or is it really just my setup?
Pic's are for example of how I set the axis's.
Thanks.

Offline Chaoticone

*
  • *
  •  5,626 5,626
  • Precision Chaos
    • View Profile
I think the problem is more your gamepad. I have had them stick before with similar results. Some of them are so very sensative. Something that may help, in the axis settings, change it from linear to expot. 2.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline Tarak

*
  •  227 227
    • View Profile
Hi Brett, I changed the controller so as a different part was controlling the X axis, but it's still doing it.
I've also noticed that it ONLY happens with X, also the saving problem is only happening with Joystick Axis 5.

Offline Chaoticone

*
  • *
  •  5,626 5,626
  • Precision Chaos
    • View Profile
I think that is because the joy stick only has 4 true axis. The D-pad is only switches I think. I think it needs to be analog to be considered a true axis in keygrabber.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline Tarak

*
  •  227 227
    • View Profile
I've tried setting X to the left or the right thumb toggle, they both work great (except for X axis sticking on) but it just won't save the setting for X.
Every time I open Mach/Keygrabber I need to re-enter the X axis and it works untill I restart Mach/keygrabber......got me knackered.
I was going to force the command then make the Default.grab file read only, but I can't work out how to enter it.

Here the settings I have im my default.grab:
The pic is the settings, I'm trying to get to stay.

KEYGRABBER CONFIG1
Controllers.InstanceID 0 {979C2240-5BC1-11DC-8001-444553540000}
Controllers.Enabled 0 1
Controllers.InstanceID 1 {00000000-0000-0000-0000-000000000000}
Controllers.InstanceID 2 {00000000-0000-0000-0000-000000000000}
Controllers.InstanceID 3 {00000000-0000-0000-0000-000000000000}
HIDKeys.KeyCode 0 0 3 192
HIDKeys.KeyCode 0 0 4 45
HIDKeys.KeyCode 0 0 7 219
HIDKeys.KeyCode 0 0 10 222
HIDKeys.KeyCode 0 0 33 36
Joysticks.Controls 0 0 3
Joysticks.GainSrc 0 0 75
Joysticks.Reverse 0 0 1
Joysticks.Controls 0 2 7
Joysticks.GainSrc 0 2 90
Joysticks.Controls 0 3 2
Joysticks.GainSrc 0 3 80
Joysticks.Reverse 0 3 1
Misc.Speed1 0 100

Offline Chaoticone

*
  • *
  •  5,626 5,626
  • Precision Chaos
    • View Profile
Darc, I don't have that game pad, so can't say for sure.  It looks like, in the pic you have the x on axis 4 and the y on axis 3. I have sent you a pesonal message.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
hello,
I have the same problem .
I have tried many options with "misc settings" of keygrabber but I can't get X et Y working with analog stick without having sometime have movement contining after release the stick ( only wait is to stop is make an another movement) .

I look on forums and have not found any answer.
Have you find some solution?

I want to use analog it is so easy to go from stepping to full speed.
I have no probleme to configure my game pad keys.
Thanks
Michel

Offline Sam

*
  • *
  •  987 987
    • View Profile
    • hillbillyhilton.com
I had the exact same problem with the runaway axis. I did fix it, but it has escaped memory as to what the fix was. Try reading the post by Chaotic and downloading his keygrabber profiles. I don't think that the axis will have the problem, and you can do a bit of sleuth work to find out why. http://www.machsupport.com/forum/index.php/topic,1391.0.html
"CONFIDENCE: it's the feeling you experience before you fully understand the situation."
Thanks for your reply.
I load the profile files from Chaotic and have the same problem.
So I test  the  option "Axis lockout" in Misc setting of keygrabber, change it to "when bouton pressed", it look working better.
I will test on the cnc machine tomorrow.

Michel