Hello Guest it is November 28, 2021, 12:03:36 PM

Author Topic: Unwanted softlimit behaviour  (Read 2959 times)

0 Members and 1 Guest are viewing this topic.

Unwanted softlimit behaviour
« on: October 27, 2008, 04:53:07 AM »
Machine: Lathe with X and Z with homing and limits; A axis without limits or homing (rotational axis)

Having the softlimits on, I always have a warning before running a part - a softlimits warning. It is related with the lack of a softlimit in the A axis, because the instant I remove the a axis (on the config ports and pins), the warning does not appear anymore.
There is any way that mach only will take care of the axis limits that the user chooses? Because I do not have, and do not need a homing in the A axis, but I need the homing in the X and Z.

Thank you

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Unwanted softlimit behaviour
« Reply #1 on: October 27, 2008, 05:15:29 AM »
There is a known problem with Softlimits on the X axis of MachTurn. Dont use them myself but have tested for others to confirm a problem. You mention the A axis, do you have an A axis on the lathe? There is a setting in General Config to disable softlimits for A axis.

Hood
Re: Unwanted softlimit behaviour
« Reply #2 on: October 27, 2008, 07:37:37 AM »
I have a A axis, angular of course, and set to be angular on the general config.
But I did not see anything related to disable softlimit to the A axis, and I have double checked. If it exists them my problem was solved.

The X and Z softlimits are working fine.
Re: Unwanted softlimit behaviour
« Reply #3 on: October 27, 2008, 09:58:35 AM »
Hello Guys,
RC :)
Re: Unwanted softlimit behaviour
« Reply #4 on: October 29, 2008, 05:09:10 AM »
I should be almost blind... I did not see it.
Thank you all.