Hello Guest it is August 08, 2020, 07:18:37 AM

Author Topic: homing does not show the 0 position  (Read 2922 times)

0 Members and 1 Guest are viewing this topic.

homing does not show the 0 position
« on: October 18, 2008, 05:13:39 AM »
hi all
i am using the galil 2123 controller with mach3 software.
some time after pressing the home Reference home button  " homing indication" on mach3 window does not show the 0 position.
 i did the setting in home/limit configuration.
please provide the solution.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: homing does not show the 0 position
« Reply #1 on: October 18, 2008, 06:39:46 AM »
Are you saying that the Config menu, homing and limits then check the Auto Zero option does not work? If that is the case then how does your homing actually work, is it controlled via the Galil? If so then you may need to have a custom Ref All button.

Hood
Re: homing does not show the 0 position
« Reply #2 on: October 18, 2008, 07:09:49 AM »
your you are saying partially write.
my homing action take place correctly( my motor stop at home). but after that  mach3 window suppose to show the 0 position but rarely it does not show 0 position.
yes it is controlled via galil. but in galil samrt terminal software homing action take correctly with showing position zero.
can explain the custom Ref All button.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: homing does not show the 0 position
« Reply #3 on: October 18, 2008, 07:39:09 AM »
I am not sure how the Galil does the homing but I will give you an example of how my lathe homes.
 On my Lathe the homing is done externally from Mach, it is the servo drives that do the homing. I send a signal to the drive, it moves the axis until the drive sees the home switch being activated, the drive then searches for the index pulse on the encoder and then moves back a set distance of my choice. Once that is complete the drive sends a signal to Mach and Mach zeros the DRO, it then moves on to the next axis and does exactly the same.
 I have custom VB code in my Ref All button to achieve this, it is as follows

DoOemButton (240)                     'De-Reference All axis
 Sleep(10)
 If GetOemLED (809) Then               'Check that Ref Z LED is RED
  Do
   Call SetModOutput (20,1)             'Activate ModOutPut 20
    If GetInput(18) Then Exit Do       'Loop until ModInPut 18 is seen
    Sleep (10)
    Loop
    End If
    Call SetModOutPut (20,0)            'DeActivate ModOutPut 20
    DoOemButton (1024)                       'Set Z axis Home
   
   
 If GetOemLED (807) Then
  Do
   Call SetModOutPut (21,1)
    If GetInput(19) Then Exit Do
    Sleep (10)
    Loop
    End If
    Call SetModOutPut (21,0)
    DoOemButton (1022)   


As none of my home switches are actually connected to Mach I have to make sure the Home switches are not activated in Ports and Pins.

Hood
« Last Edit: October 18, 2008, 07:44:15 AM by Hood »
Re: homing does not show the 0 position
« Reply #4 on: October 20, 2008, 03:12:15 AM »
hi sir
      i have enable the home switch in port and pin setting.(i am using mach3 with galil). does this make any problem.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: homing does not show the 0 position
« Reply #5 on: October 20, 2008, 06:02:45 AM »
It may be a problem but it will depend on how the Galil and Mach do the homing, as I said on my lathe I have it set so homing is done external from Mach so all that is required of Mach is to zero the DROs when the drive has completed the homing. If I had the home switches enabled in Ports and Pin Mach itself would start moving my axis and that is not what I want in my setup, yours may well be different.
 If you have an E-Stop what you can do is disable the limits in Ports and Pins, do a ref and see if it works but be ready with the E-Stop just in case it goes wrong.
Hood
« Last Edit: October 20, 2008, 06:04:29 AM by Hood »