Hello Guest it is March 05, 2021, 09:06:10 PM

Author Topic: reinstalling mach3  (Read 13433 times)

0 Members and 1 Guest are viewing this topic.

reinstalling mach3
« on: September 28, 2008, 10:00:28 PM »
how to reinstall mach3.................mike hide
Re: reinstalling mach3
« Reply #1 on: September 28, 2008, 10:41:49 PM »
Mike,

    Just run the installer again.  Rename your XML file, or do the new install to a different directory, then copy your XML over after the install.

Regards,
Ray L.
Regards,
Ray L.
Re: reinstalling mach3
« Reply #2 on: September 30, 2008, 01:52:54 PM »
Thanks Ray for your help .I have been piddling with this for some time and still no joy . perhaps the installation from the start was not correct .Iam still having problems with mach mill . whhen I hit the icon I get a flash screen showing the mach mill introduction screen then everything just goes blank . If I do the same to the turn iconit brings that uo fine  withe the lazycam icon I get a notice saying I have a mach2 version loaded.

I went back to the downloads section and loaded the latest version [I think of may this year] I still have the same problem .Now I dont know ifthw whole thing is messed up or not seems what I downloaded was not he complete system otherwise the mach3mill should have turned up when selected .

To complicate things even more I have indications that ,Lost "enable40.dll" as far as that is concerned I have checked and thayt folder is still in Mach 3 folder.Other things that do not seem to be in the path are c:\winnt\system32; c:\winnt\system.

In short I am totally out of my depth and need very explicit instuctions if anyone knows what is wrong..From an absolute bald headed [all hair removed] novice,by the way I have searcged for the "installer " and there is no file by that name on my hard drive   regards mike hide
Re: reinstalling mach3
« Reply #3 on: September 30, 2008, 02:28:34 PM »
Before reinstalling, save your mach3mill.xml and license file (something like mach1lic.dat).
Joe
Re: reinstalling mach3
« Reply #4 on: September 30, 2008, 05:41:20 PM »
Thanks Ray for your help .I have been piddling with this for some time and still no joy . perhaps the installation from the start was not correct .Iam still having problems with mach mill . whhen I hit the icon I get a flash screen showing the mach mill introduction screen then everything just goes blank . If I do the same to the turn iconit brings that uo fine withe the lazycam icon I get a notice saying I have a mach2 version loaded.

I went back to the downloads section and loaded the latest version [I think of may this year] I still have the same problem .Now I dont know ifthw whole thing is messed up or not seems what I downloaded was not he complete system otherwise the mach3mill should have turned up when selected .

To complicate things even more I have indications that ,Lost "enable40.dll" as far as that is concerned I have checked and thayt folder is still in Mach 3 folder.Other things that do not seem to be in the path are c:\winnt\system32; c:\winnt\system.

In short I am totally out of my depth and need very explicit instuctions if anyone knows what is wrong..From an absolute bald headed [all hair removed] novice,by the way I have searcged for the "installer " and there is no file by that name on my hard drive regards mike hide

Mike,

    I'd suggest you backup your XML and license files, then go to ControlPanel->Add or Remove Programs, and un-install and Mach2, Mach3, LazyCAM, etc. you find there.  Then go into MyComputer and delete the directories, if the un-install left any of them lying around.  Finally, re-install Mach3, and copy the XML and license files into the new install directories.  Sounds to me like you've got a mix of Mach2 and Mach3, perhaps installed on top of each other.  The bext thing to do is just start clean.  It should be very simple....

Regards,
Ray L.
Regards,
Ray L.
Re: reinstalling mach3
« Reply #5 on: October 01, 2008, 02:32:35 AM »
This is some what scary as far as I am concerned. regarding the xml files is it ok ito copy them to a removable drive[memory stick]  and do i copy them all ?

Secondly I got into the existing registry and did not see any Mach files even when I expanded most of the arrows,if you could give some guidance it would be appreciated as where they are....regards mike hide
Re: reinstalling mach3
« Reply #6 on: October 01, 2008, 10:43:16 AM »
Mike,

    Look in your Mach3 directory, sort the display by file type, and scroll all the way to the bottom.  You should see just a few files of type "XML Document" (I only have 3).  You'll probably have Mach3Mill.XML, LazyCAM.XML, and maybe a customized XML - that's the one you really need.  If you don't have a customized XML, then Mach3Mill.XML is the one you care about.  Just copy it to another directory, a USB drive, or wherever is convenient.  After re-installing Mach3, copy it to the new installation directory.
   There's no need to muck with the registry at all.

Regards,
Ray L.
Regards,
Ray L.
Re: reinstalling mach3
« Reply #7 on: October 01, 2008, 04:51:28 PM »
Ok Ray thanks for the help, I have the followiing xml files transferred to the external drive plus the licence. lazycam,plasma,screen4,mach3 mill.and mach3turn.

now where is the new Mach 3 filefor installation and how do i get the xml files and licence installed...? regsds mike hide
Re: reinstalling mach3
« Reply #8 on: October 01, 2008, 11:02:50 PM »
Forgot to mention mach and its bits and pieces have now been deleted , and as far as I cn see there is nothing left in the registry
Re: reinstalling mach3
« Reply #9 on: October 01, 2008, 11:45:10 PM »
Mike,

    You can download Mach3 from here: http://www.machsupport.com/downloads.php

    Run the installer, then just copy all your files into the install directory, and you should be good to go.

Regards,
Ray L.
Regards,
Ray L.