Hello Guest it is December 10, 2019, 05:31:08 AM

Author Topic: Running Mach Without Hardware  (Read 6967 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Running Mach Without Hardware
« Reply #10 on: September 14, 2008, 04:53:52 PM »
The simulate is meant just to run through the code quickly and tell you how long it will take to complete, you do not see a representation of what it does on the screen . It is basically a check to make sure it will run and what time it will take.
 If you want to see a real time run through just press start like you would normally.
Hood
Re: Running Mach Without Hardware
« Reply #11 on: September 14, 2008, 05:03:01 PM »
Hood,

   Well, it sure gives a lousy estimate of the run time, then.  It's off by a factor of 10 or more.  When I try to run it normally, it just hangs at line 110.  No DRO updates, no path updates, nothing.

Regards,
Ray L.
Regards,
Ray L.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Running Mach Without Hardware
« Reply #12 on: September 14, 2008, 05:04:45 PM »
please attach your code and I will see if it acts the same here
Hood
Re: Running Mach Without Hardware
« Reply #13 on: September 14, 2008, 05:33:52 PM »
Hood,

    Code is attached.  Note this is setup for 2D milling, manual Z, so there are M00s where each Z move would be.

Regards,
Ray L.
Regards,
Ray L.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Running Mach Without Hardware
« Reply #14 on: September 14, 2008, 05:37:30 PM »
Runs through fine here, says it will take 38mins 56 seconds.
Hood
Re: Running Mach Without Hardware
« Reply #15 on: September 14, 2008, 05:48:49 PM »
Hood,

    Interesting....  This was a fresh install of v3.041 on a new laptop.  Is there some configuation I need to do?

Regards,
Ray L.
Regards,
Ray L.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Running Mach Without Hardware
« Reply #16 on: September 14, 2008, 05:50:08 PM »
you got the xml from your machine in there?
Hood

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Running Mach Without Hardware
« Reply #17 on: September 14, 2008, 05:53:21 PM »
Actually had my motors tuning set way down, put it back up and its now saying 37mins simulation, It will however depend what your rapids are set to what time is actually calculated as rapids are taken into account when simulating.
Hood

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Running Mach Without Hardware
« Reply #18 on: September 14, 2008, 05:57:30 PM »
Just out of curiousity, what material are you cutting, feeds and spindle seem really slow unless is 316 with HSS cutters.
Hood
Re: Running Mach Without Hardware
« Reply #19 on: September 14, 2008, 06:02:09 PM »
you got the xml from your machine in there?
Hood

Hood,

    No, just using whatever was there in the install, which is reasonably close to the real thing in terms of rapid speed.

    That part was 304 SS, with HSS tools - my first ever SS project.  Came out perfect, and only ruined one tool, when the coolant stopped mid-cut.

Regards,
Ray L.
Regards,
Ray L.