Hello Guest it is January 24, 2022, 01:25:29 AM

Author Topic: Wizzards no longer generate g-code but move machine instead  (Read 3226 times)

0 Members and 1 Guest are viewing this topic.

I retrofitted a Trumpf waterjet machine with Mach3 and a controller by CS-lab three years ago. It worked and works fine and is mainly used to cut foam for packaging. Today I finished a wizard to generate code to cut rectangles from foam and it works fine on my computer, but when I copied it onto the machine and ran it there, it moved the machine instead of creating a file. First I thought it was a bug in my wizard, but as I tested others I found out that they all behave that way. We did use the "Nested"-wizard that came with Mach3 in the beginning and it worked just fine. But now all it does is show the loaded subroutine (a circle in this case) and move the machine in triangles, no code is created.
My own wizard moves the machine more or less in the way the code should be created, but it doesn't create and load the file it is supposed to do and does on my computer. If the motors are not active, I get ans ePID error...

Any ideas what could cause this behavior of Mach3 on the machine? Any settings known that might have been changed since it last worked (we didn't use any wizards in quite some time) that could cause this?

Offline Tarak

*
  •  229 229
    • View Profile
Re: Wizzards no longer generate g-code but move machine instead
« Reply #1 on: July 25, 2016, 11:07:43 PM »
I got caught out once because at the top of my program I didn't put the following:

OpenTeachFile "Program.cnc"

This would start moving the machine, not sure if this is relevant for you though!
Re: Wizzards no longer generate g-code but move machine instead
« Reply #2 on: July 28, 2016, 11:04:49 AM »
Thank you for the suggestion!
Unfortunately our problem must lie somewhere else, since the line it there in my wizard and none of the wizards included with Mach3 work anymore either.

But it still might point to some problem with the path of the teachfile, like missing writing access to the directory or something like that. I'll check that the next time I'm at the machine. It'll be at least two weeks tough...