Hello Guest it is March 09, 2021, 02:31:34 AM

Author Topic: After using the “Steps Per Unit” in “Axis Calibration” my CNC wont run properly  (Read 30913 times)

0 Members and 1 Guest are viewing this topic.



When I moved from full to 1/8 step I could no longer run the Y axis at 100 had to drop to I think 60. Why would that be?

Because Mach3 can't output steps fast enough, unless you change to a faster kernel speed.

Where does it show the kernel speed?  And what are my options?

Hey Gerry you really get around.  Guess that happens when you are knowledgeable and in demand

Thanks
Mr. Chips
Retired 3M'r

Offline RICH

*
  • *
  •  7,419 7,419
    • View Profile
Sorry about that,.... loose steps.
Nothing magical, just try different materials and cutting depths and see what works.  Try the 1/4" dia x 1/4 deep at say 10 ipm, then 20
or whatever, won't take too long before you know what your machinie can do.

Before you make test cuts, get your motor tuning done.
RICH

Offline ger21

*
  • *
  •  6,289 6,289
    • View Profile
    • The CNC Woodworker
1/8 step should be 16,000 steps, btw. 8 x 200 x 10
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
1/8 step should be 16,000 steps, btw. 8 x 200 x 10

I am so Confused Stupid or Both.

Start settings:
1/8 step at 32,000 steps settings  X1 draws a line 1" long

I go into Motor Tuning and change the steps/unit to 16,000 for all 3 axis, saving each axis.

Now i get:
1/8 step at 16,000 steps settings  X1 draws a line 1" long

What it wrong?  At 16,000 steps/unit shouldnt the line be 1/2" long?????

What am I doing wrong???
Mr. Chips
Retired 3M'r

Offline bowber

*
  •  216 216
  • Kirkby Stephen,Cumbria, UK
    • View Profile
On a direct drive 10tpi lead screw with 200 step per rev steppers set to 1/8 microstepping 16000 steps per inch is the correct setting, no idea how you got 32000 to work.
I set my steps per by calculating it and then tested at low acceleration and speed, then did the top speed and acceleration to suit, my mill is set way below what it's able to run but I'd rather have it cutting right and take a little longer about rapids than loose steps.
Mine is a mill though and doesn't have the travel your router has, however I bet it weighs a bit more :)

Steve
I am setting the steps in "Motor Tuning, Steps Per".

Is this the correct place to define the steps?
Mr. Chips
Retired 3M'r
That's the right place, make sure you hit the ENTER key whenever you change it though.
RC
I always hit the enter as well as the SAVE SETTINGS button. Had trouble early on with settings not "Taking".
RC
I always hit the enter as well as the SAVE SETTINGS button. Had trouble early on with settings not "Taking".
RC


YES hitting "Enter" is the trick!!!

Now I have another question now that the "Motor Tuning, Steps Per" is working.

I wrote GCode to draw a 1" square.  Results below.
Why is the 32,000 run way off size and a rectangle.  I was expecting it to be 2"  Any ideas.  I know this is off topic, and I know how to draw a 1" square now, but it doesn't make sense.

At 32,000 it draws a square that is 1.026" X 1.104  Not square
At 16,000 it draws a square that is 0.986"
At 8,000 it draws a square that is 0.489"
At 4,000 it draws a square that is 0.224"

THanks
Mr. Chips
Retired 3M'r

Offline Kristin D

*
  •  203 203
  • Take that you LazyCam, next stop the glue factory!
    • View Profile
The square could be out due to backlash in one or both axis, when you generated/wrote the g-code did you offset for half the cutter diameter?

Kristin